방명록 - 윈디하나의 솔라나라

솔라나라 방명록 사용 안내
솔라나라의 방명록입니다. 건의 및 문의사항도 이곳에 남겨주세요.
안녕하세요. 좋은 사이트다!!

주로 리눅스를 사용하는데 솔라리스를 접해보고 싶어 설치해봐도 자료도 없고 그러다보니
잘 적응이 안되어 지우곤 했는데 좋은 자료를 많이 만들어주셔서 감사합니다.
잘 보고 배우도록 할께요. 저도 언젠가 좋은 컨텐츠를 만들어서 나눌 수 있으면 좋겠네요.

다시한번 감사드립니다. 건강하세요.
이대규 (2022.08.08) 삭제


https://www.solanara.net/solanara/solaris11#head_solaris11_conf_compiler
위 문서를 참고하여 컴파일러 설치를 하고 있는데,
아래와 같은 메세지가 발생하면서 설치가 안되고 있습니다.
solarisstudio 인증서는 받아서 설치했고, 순서대로 명령어를 따라 실행해봤는데 결과는 아래와 같습니다.

user@sola11:~$ sudo pkg set-publisher \
> -k ~pss/pkg.oracle.com.key.pem \
> -c ~pss/pkg.oracle.com.certificate.pem \
> -G '*' -g https://pkg.oracle.com/solarisstudio/release solarisstudio
user@sola11:~$ sudo pkg publisher solarisstudio

Publisher: solarisstudio
Alias:
Origin URI: https://pkg.oracle.com/solarisstudio/release/
Origin Status: Online
SSL Key: /var/pkg/ssl/662827724bf02423d6d224eaedefd0c16f38c7d0
SSL Cert: /var/pkg/ssl/cfc1eb05960c20bcbad30470da91c5d17b713421
Cert. Effective Date: Tue Jul 19 11:32:35 2022
Cert. Expiration Date: Fri Jul 26 11:32:35 2024
Client UUID: f5631a2a-e93a-11ec-91b5-7b5a9ab4c615
Catalog Updated: Mon May 21 22:20:27 2018
Publisher enabled: Yes
user@sola11:~$ sudo pkg install --accept developerstudio-126
Creating Plan (Running solver): |
pkg install: No matching version of developer/developerstudio-126 can be installed:
Reject: pkg://solarisstudio/developer/developerstudio-126@12.6-1.0.0.1
Reason: No version matching 'require' dependency developer/developerstudio-126/c++@12.6-1.0.0.1 can be installed
----------------------------------------
Reject: pkg://solarisstudio/developer/developerstudio-126/c++@12.6-1.0.0.1
Reason: No version matching 'require' dependency library/c++/stdcxx can be installed
----------------------------------------
Reject: pkg://solaris/library/c++/stdcxx@4.2.1-11.4.0.0.1.14.0
Reason: This version is excluded by installed incorporation consolidation/userland/userland-incorporation@11.4-11.4.42.0.0.111.0
----------------------------------------
----------------------------------------
user@sola11:~$

'require' dependency 를 찾을수 없다고 나오는데 어떻게 조치를 해야 하는지 문의드립니다.
감사합니다.
redjacob (2022.07.30) 삭제
솔라리스 버전이 11.4 인지요? 11.4.42 가 나와서 이거 먼저 업그레이드 해야 할것 같네요. 오류메시지는 패키지를 못 찾는건데 패키지가 없진 않아서요.
- 윈디하나 -


안녕하세요...
다시 오픈 되었군요...
혹시 sol9 x86 다운로드 받을 수있는곳이 있을 까요 ?
급하게 필요 합니다...
황준호 (2021.09.28) 삭제
- 현재 공식적으로는 다운로드를 제공하는 곳이 없습니다. 유지보수 업체에 문의하면 아마 가지고 있을겁니다.
- 윈디하나 -


많지 않은 Solaris 관련 Site 중에서 이곳을 찾아 많은 정보와 도움 받아 갑니다. 감사합니다. 수고하세요. :)
Jay (2020.09.26) 삭제
- 솔라리스 시작하신다니 반갑네요. 앞으로도 많은 관심 부탁드립니다.
- 윈디하나 -


안녕하게요. 솔라리스를 처음 접한 컴공 학생입니다
VMware Workstation으로 설치를 하려는데

solaris tmpfs: WARNING: /system/volatile: File system full, space limit exceeded
svc.startd: Repository server out of resources.

INIT: Couldn't write persistent state file '/system/volatile/init.state'.

이렇게 뜨면서 설치 창으로 안 넘어가지더라고요
재시작도 해봤는데도 버벅대니까 일단 끄고
이런 사이트를 찾아서 글 남깁니다
고정수 (2020.09.11) 삭제
- VMWARE은 요즘에 사용하질 않아서 잘 모르겠습니다만, 메시지만 보면 Repository server out of resources, 즉 리소스 부족이고

solaris tmpfs: WARNING: /system/volatile: File system full, space limit exceeded

으로 봐서는 tmpfs (메모리 기반 파일 시스템, SWAP 영역) 가 부족한걸로 되어있네요.

- 설치중에 나온거라면 VMWARE 의 메모리를 좀 더 주고 설치해보세요. 적어도 4GB이상은 주어야 합니다.

- 앞으로도 많은 관심 부탁드립니다.
- 윈디하나 -


1 2 3 4 5 6 7 8 9 10 11

방명록 등록하기

* 필수 입력 항목
이름 *
암호 * 삭제시 사용할 비밀번호를 간단히 입력해주세요.
재입력 * 비밀번호를 다시 입력해주세요.
연락처 관리자가 연락할 수 있는 메일 주소 또는 전화번호를 적어주세요.
본문 * (이모지를 사용할 수 있습니다. 🎀 HTML 태그를 사용하실 수 없습니다)
등록 초기화
RSS ATOM XHTML 5 CSS3