svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
mount(8)
System Administration Commands mount(8)
NAME
mount, umount - mount or unmount file systems and remote resources
SYNOPSIS
mount [-p | -v]
mount [-F FSType] [generic_options] [-o specific_options]
[-O] special | mount_point
mount [-F FSType] [generic_options] [-o specific_options]
[-O] special mount_point
mount -a [-F FSType] [-V] [current_options]
[-o specific_options] [mount_point]...
umount [-f] [-V] [-o specific_options] special | mount_point
umount -a [-f] [-V] [-o specific_options] [mount_point]...
DESCRIPTION
mount attaches a file system to the file system hierarchy at the
mount_point, which is the pathname of a directory. If mount_point has
any contents prior to the mount operation, these are hidden until the
file system is unmounted.
umount unmounts a currently mounted file system, which may be specified
either as a mount_point or as special, the device on which the file
system resides.
The table of currently mounted file systems can be found by examining
the mounted file system information file. This is provided by a file
system that is usually mounted on /etc/mnttab. The mounted file system
information is described in mnttab(5). Mounting a file system adds an
entry to the mount table; a umount removes an entry from the table.
When invoked with both the special and mount_point arguments and the -F
option, mount validates all arguments except for special and invokes
the appropriate FSType-specific mount module. If invoked with no argu‐
ments, mount lists all the mounted file systems recorded in the mount
table, /etc/mnttab. If invoked with a partial argument list (with only
one of special or mount_point, or with both special or mount_point
specified but not FSType), mount will search /etc/vfstab for an entry
that will supply the missing arguments. If no entry is found, and the
special argument starts with /, the default local file system type
specified in /etc/default/fs will be used. Otherwise the default remote
file system type will be used. The default remote file system type is
determined by the first entry in the /etc/dfs/fstypes file. After fill‐
ing in missing arguments, mount will invoke the FSType-specific mount
module.
For file system types that support it, a file can be mounted directly
as a file system by specifying the full path to the file as the special
argument. In such a case, the nosuid option is enforced. If specific
file system support for such loopback file mounts is not present, you
can still use lofiadm(8) to mount a file system image. In this case, no
special options are enforced.
Only a user with sufficient privilege (at least PRIV_SYS_MOUNT) can
mount or unmount file systems using mount and umount. However, any user
can use mount to list mounted file systems and resources.
OPTIONS
-F FSType
Used to specify the FSType on which to operate. The FSType must be
specified or must be determinable from /etc/vfstab, or by consult‐
ing /etc/default/fs or /etc/dfs/fstypes.
-a [ mount_points. . . ]
Perform mount or umount operations in parallel, when possible.
If mount points are not specified, mount will mount all file sys‐
tems whose /etc/vfstab "mount at boot" field is yes. If mount
points are specified, then /etc/vfstab "mount at boot" field will
be ignored.
If mount points are specified, umount will only umount those mount
points. If none is specified, then umount will attempt to unmount
all file systems in /etc/mnttab, with the exception of certain sys‐
tem required file systems: /, /usr, /var, /var/adm, /var/run,
/proc, /dev/fd and /tmp.
-f
Forcibly unmount a file system.
Without this option, umount does not allow a file system to be
unmounted if a file on the file system is busy. Using this option
can cause data loss for open files; programs which access files
after the file system has been unmounted will get an error (EIO).
-p
Print the list of mounted file systems in the /etc/vfstab format.
Must be the only option specified.
-v
Print the list of mounted file systems in verbose format. Must be
the only option specified.
-V
Echo the complete command line, but do not execute the command.
umount generates a command line by using the options and arguments
provided by the user and adding to them information derived from
/etc/mnttab. This option should be used to verify and validate the
command line.
generic_options
Options that are commonly supported by most FSType-specific command
modules. The following options are available:
-m
Mount the file system without making an entry in /etc/mnttab.
-g
Globally mount the file system. On a clustered system, this
globally mounts the file system on all nodes of the cluster. On
a non-clustered system this has no effect.
-o
Specify FSType-specific options in a comma separated (without
spaces) list of suboptions and keyword-attribute pairs for
interpretation by the FSType-specific module of the command.
(See mount_ufs(8).) When you use -o with a file system that has
an entry in /etc/vfstab, any mount options entered for that
file system in /etc/vfstab are ignored.
The following options are supported:
devices | nodevices
Allow or disallow the opening of device-special files. The
default is devices.
If you use nosuid in conjunction with devices, the behavior
is equivalent to that of nosuid.
exec | noexec
Allow or disallow executing programs in the file system.
Allow or disallow mmap(2) with PROT_EXEC for files within
the file system. The default is exec.
loop
Ignored for compatibility.
nbmand | nonbmand
Allow or disallow non-blocking mandatory locking semantics
on this file system. Non-blocking mandatory locking is dis‐
allowed by default.
If the file system is mounted with the nbmand option, then
applications can use the fcntl(2) interface to place non-
blocking mandatory locks on files and the system enforces
those semantics. If you enable this option, it can cause
standards conformant applications to see unexpected errors.
To avoid the possibility of obtaining mandatory locks on
system files, do not use the nbmand option with the follow‐
ing file systems:
/
/usr
/etc
/var
/proc
/dev
/devices
/system/contract
/system/object
/etc/mnttab
/etc/dfs/sharetab
Do not use the remount option to change the nbmand disposi‐
tion of the file system. The nbmand option is mutually
exclusive of the global option. See -g.
ro | rw
Specify read-only or read-write. The default is rw.
setuid | nosetuid
Allow or disallow setuid or setgid execution. The default
is setuid.
If you specify setuid in conjunction with nosuid, the
behavior is the same as nosuid.
nosuid is equivalent to nosetuid and nodevices. When suid
or nosuid is combined with setuid or nosetuid and devices
or nodevices, the most restrictive options take effect.
This option is highly recommended whenever the file system
is shared by way of NFS with the root= option. Without it,
NFS clients could add setuid programs to the server or cre‐
ate devices that could open security holes.
suid | nosuid
Allow or disallow setuid or setgid execution. The default
is suid. This option also allows or disallows opening any
device-special entries that appear within the filesystem.
nosuid is equivalent to nosetuid and nodevices. When suid
or nosuid is combined with setuid or nosetuid and devices
or nodevices, the most restrictive options take effect.
This option is highly recommended whenever the file system
is shared using NFS with the root=option, because, without
it, NFS clients could add setuid programs to the server, or
create devices that could open security holes.
rstchown | norstchown
Allow or disallow restricted chown. If the file system is
mounted with rstchown, the owner of the file is prevented
from changing the owner ID of the file. If the file system
is mounted with norstchown, the user can permit ownership
changes for files they own. Only the super-user or a user
with appropriate privilege can arbitrarily change owner
IDs.
-O
Overlay mount. Allow the file system to be mounted over an
existing mount point, making the underlying file system inac‐
cessible. If a mount is attempted on a pre-existing mount point
without setting this flag, the mount will fail, producing the
error "device busy".
-r
Mount the file system read-only.
EXAMPLES
Example 1 Mounting and Unmounting a DVD Image Directly
The following commands mount and unmount a DVD image.
# mount -F hsfs /images/solaris.iso /mnt/solaris-image
# umount /mnt/solaris-image
FILES
/etc/mnttab
Table of mounted file systems.
/etc/default/fs
Default local file system type. Default values can be set for the
following flags in /etc/default/fs. For example: LOCAL=ufs
LOCAL:
The default FSType for a command if one is not specified.
/etc/vfstab
List of default parameters for each file system.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Availabilitysystem/core-os
SEE ALSO
mmap(2), fcntl(2), lofs(4FS), pcfs(4FS), zfs(4FS), mnttab(5),
vfstab(5), attributes(7), privileges(7), lofiadm(8), mount_hsfs(8),
mount_nfs(8), mount_pcfs(8), mount_smbfs(8), mount_tmpfs(8),
mount_udfs(8), mount_ufs(8), mountall(8), umountall(8), zfs(8)
NOTES
If the directory on which a file system is to be mounted is a symbolic
link, the file system is mounted on the directory to which the symbolic
link refers, rather than on top of the symbolic link itself.
ZFS filesystems are usually mounted with zfs mount and zfs unmount
instead of these commands. See zfs(8) for more information.
Oracle Solaris 11.4 26 Mar 2020 mount(8)