svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
unlockpt(3c)
Standard C Library Functions unlockpt(3C)
NAME
unlockpt - unlock a pseudo-terminal master/slave pair
SYNOPSIS
#include <stdlib.h>
int unlockpt(int fildes);
DESCRIPTION
The unlockpt() function unlocks the slave pseudo-terminal device asso‐
ciated with the master to which fildes refers.
Portable applications must call unlockpt() before opening the slave
side of a pseudo-terminal device.
RETURN VALUES
Upon successful completion, unlockpt() returns 0. Otherwise, it returns
−1 and sets errno to indicate the error.
ERRORS
The unlockpt() function may fail if:
EBADF The fildes argument is not a file descriptor open for writ‐
ing.
EINVAL The fildes argument is not associated with a master pseudo-
terminal device.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe _ Standard‐
See standards(7).
SEE ALSO
open(2), grantpt(3C), ptsname(3C), attributes(7), standards(7)
STREAMS Programming Guide
Oracle Solaris 11.4 14 Aug 2002 unlockpt(3C)