svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
timer_create(3c)
Standard C Library Functions timer_create(3C)
NAME
timer_create - create a timer
SYNOPSIS
#include <signal.h>
#include <time.h>
int timer_create(clockid_t clock_id,
struct sigevent *restrict evp, timer_t *restrict timerid);
DESCRIPTION
The timer_create() function creates a timer using the specified clock,
clock_id, as the timing base. The timer_create() function returns, in
the location referenced by timerid, a timer ID of type timer_t used to
identify the timer in timer requests. This timer ID will be unique
within the calling process until the timer is deleted. The particular
clock, clock_id, is defined in <time.h>. The timer whose ID is returned
will be in a disarmed state upon return from timer_create().
The evp argument, if non-null, points to a sigevent structure. This
structure, allocated by the application, defines the asynchronous noti‐
fication that will occur when the timer expires (see signal.h(3HEAD)
for event notification details). If the evp argument is NULL, the
effect is as if the evp argument pointed to a sigevent structure with
the sigev_notify member having the value SIGEV_SIGNAL, the sigev_signo
having the value SIGALARM, and the sigev_value member having the value
of the timer ID.
If the sigev_notify member of the sigeven structure has the value
SIGEV_SIGNAL_THR, the signal number specified in sigev_signo will be
sent to the calling thread. When the thread exits, this timer will be
deleted automatically.
The system defines a set of clocks that can be used as timing bases for
per-process timers. The following values for clock_id are supported:
CLOCK_REALTIME wall clock
CLOCK_VIRTUAL user CPU usage clock
CLOCK_PROF user and system CPU usage clock
CLOCK_HIGHRES non-adjustable, high-resolution clock
CLOCK_PROCESS_CPUTIME_ID process CPU time clock
CLOCK_THREAD_CPUTIME_ID thread CPU time clock
As well as the above values, clock_id can be specified as the Clock ID
returned by clock_getcpuclockid(3C) or pthread_getcpuclockid(3C).
For timers created with a clock_id of CLOCK_HIGHRES, the system will
attempt to use an optimal hardware source. This may include, but is not
limited to, per-CPU timer sources. The actual hardware source used is
transparent to the user and may change over the lifetime of the timer.
For example, if the caller that created the timer were to change its
processor binding or its processor set, the system may elect to drive
the timer with a hardware source that better reflects the new binding.
Timers based on a clock_id of CLOCK_HIGHRES are ideally suited for
interval timers that have minimal jitter tolerance.
Timers are not inherited by a child process across a fork(2) and are
disarmed and deleted by a call to one of the exec functions (see
exec(2)).
RETURN VALUES
Upon successful completion, timer_create() returns 0 and updates the
location referenced by timerid to a timer_t, which can be passed to the
per-process timer calls. If an error occurs, the function returns −1
and sets errno to indicate the error. The value of timerid is undefined
if an error occurs.
ERRORS
The timer_create() function will fail if:
EAGAIN The system lacks sufficient signal queuing resources to honor
the request, or the calling process has already created all
of the timers it is allowed by the system.
EINVAL The specified clock ID, clock_id, is not defined.
EPERM The specified clock ID, clock_id, is CLOCK_HIGHRES and the
{PRIV_PROC_CLOCK_HIGHRES} is not asserted in the effective
set of the calling process.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe with
exceptions _ StandardSee standards(7).
SEE ALSO
exec(2), fork(2), time(2), clock_settime(3C), clock_getcpuclockid(3C),
pthread_getcpuclockid(3C), signal(3C), timer_delete(3C), timer_set‐
time(3C), signal.h(3HEAD), attributes(7), privileges(7), resource-con‐
trols(7), standards(7)
Oracle Solaris 11.4 22 Jan 2019 timer_create(3C)