svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
sem_close(3c)
Standard C Library Functions sem_close(3C)
NAME
sem_close - close a named semaphore
SYNOPSIS
#include <semaphore.h>
int sem_close(sem_t *sem);
DESCRIPTION
The sem_close() function is used to indicate that the calling process
is finished using the named semaphore indicated by sem. The effects of
calling sem_close() for an unnamed semaphore (one created by
sem_init(3C)) are undefined. The sem_close() function deallocates (that
is, make available for reuse by a subsequent sem_open(3C) by this
process) any system resources allocated by the system for use by this
process for this semaphore. The effect of subsequent use of the sema‐
phore indicated by sem by this process is undefined. If the semaphore
has not been removed with a successful call to sem_unlink(3C), then
sem_close() has no effect on the state of the semaphore. If the
sem_unlink(3C) function has been successfully invoked for name after
the most recent call to sem_open(3C) with O_CREAT for this semaphore,
then when all processes that have opened the semaphore close it, the
semaphore is no longer be accessible.
RETURN VALUES
If successful, sem_close() returns 0, otherwise it returns −1 and sets
errno to indicate the error.
ERRORS
The sem_close() function will fail if:
EINVAL The sem argument is not a valid semaphore descriptor.
ENOSYS The sem_close() function is not supported by the system.
USAGE
The sem_close() function should not be called for an unnamed semaphore
initialized by sem_init(3C).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
sem_init(3C), sem_open(3C), sem_unlink(3C), attributes(7), standards(7)
Oracle Solaris 11.4 31 Jan 2012 sem_close(3C)