svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_getcpuclockid(3c)
Standard C Library Functions pthread_getcpuclockid(3C)
NAME
pthread_getcpuclockid - access a thread CPU-time clock
SYNOPSIS
#include <pthread.h>
#include <time.h>
int pthread_getcpuclockid(pthread_t thread_id, clockid_t *clock_id);
DESCRIPTION
The pthread_getcpuclockid() function shall return in clock_id the clock
ID of the CPU-time clock of the thread specified by thread_id if the
thread described by thread_id exists.
RETURN VALUES
On successful completion, pthread_getcpuclockid() shall return 0; oth‐
erwise an error shall be returned to indicate the error
ERRORS
The pthread_getcpuclockid() function may fail if:
ESRCH The thread specified by thread_id does not exist.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
clock_getcpuclockid(3C), clock_getres(3C), timer_create(3C),
attributes(7), standards(7)
Oracle Solaris 11.4 17 Jan 2019 pthread_getcpuclockid(3C)