svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
mq_close(3c)
Standard C Library Functions mq_close(3C)
NAME
mq_close - close a message queue
SYNOPSIS
#include <mqueue.h>
int mq_close(mqd_t mqdes);
DESCRIPTION
The mq_close() function removes the association between the message
queue descriptor, mqdes, and its message queue. The results of using
this message queue descriptor after successful return from this
mq_close(), and until the return of this message queue descriptor from
a subsequent mq_open(3C), are undefined.
If the process (or thread) has successfully attached a notification
request to the message queue via this mqdes, this attachment is removed
and the message queue is available for another process to attach for
notification.
RETURN VALUES
Upon successful completion, mq_close() returns 0; otherwise, the func‐
tion returns −1 and sets errno to indicate the error condition.
ERRORS
The mq_close() function will fail if:
EBADF The mqdes argument is an invalid message queue descriptor.
ENOSYS The mq_open() function is not supported by the system.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
mq_notify(3C), mq_open(3C), mq_unlink(3C), mqueue.h(3HEAD),
attributes(7), standards(7)
Oracle Solaris 11.4 31 Jan 2012 mq_close(3C)