svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
gettxt(3c)
Standard C Library Functions gettxt(3C)
NAME
gettxt - retrieve a text string
SYNOPSIS
#include <nl_types.h>
char *gettxt(const char *msgid, const char *dflt_str);
DESCRIPTION
The gettxt() function retrieves a text string from a message file. The
arguments to the function are a message identification msgid and a
default string dflt_str to be used if the retrieval fails.
The text strings are in files created by the mkmsgs utility (see
mkmsgs(1)) and installed in directories in
/usr/lib/locale/locale/LC_MESSAGES.
The directory locale can be viewed as the language in which the text
strings are written. The user can request that messages be displayed in
a specific language by setting the environment variable LC_MESSAGES. If
LC_MESSAGES is not set, the environment variable LANG will be used. If
LANG is not set, the files containing the strings are in
/usr/lib/locale/C/LC_MESSAGES/*.
The user can also change the language in which the messages are dis‐
played by invoking the setlocale(3C) function with the appropriate
arguments.
If gettxt() fails to retrieve a message in a specific language it will
try to retrieve the same message in U.S. English. On failure, the pro‐
cessing depends on what the second argument dflt_str points to. A
pointer to the second argument is returned if the second argument is
not the null string. If dflt_str points to the null string, a pointer
to the U.S. English text string "Message not found!!\n" is returned.
The following depicts the acceptable syntax of msgid for a call to get‐
txt().
<msgid> = <msgfilename>:<msgnumber>
The first field is used to indicate the file that contains the text
strings and must be limited to 14 characters. These characters must be
selected from the set of all character values excluding \0 (null) and
the ASCII code for / (slash) and : (colon). The names of message files
must be the same as the names of files created by mkmsgs and installed
in /usr/lib/locale/locale/LC_MESSAGES/*. The numeric field indicates
the sequence number of the string in the file. The strings are numbered
from 1 to n where n is the number of strings in the file.
RETURN VALUES
Upon failure to pass either the correct msgid or a valid message number
to gettxt(), a pointer to the text string "Message not found!!\n" is
returned.
USAGE
It is recommended that gettext(3C) be used in place of this function.
EXAMPLES
Example 1 Example of gettxt() function.
In the following example,
gettxt("UX:10", "hello world\n")
gettxt("UX:10", "")
UX is the name of the file that contains the messages and 10 is the
message number.
FILES
/usr/lib/locale/C/LC_MESSAGES/*
contains default message files created by mkmsgs
/usr/lib/locale/locale/LC_MESSAGES/*
contains message files for different languages created by mkmsgs
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelSafe with exceptions
SEE ALSO
exstr(1), mkmsgs(1), fmtmsg(3C), gettext(3C), setlocale(3C),
attributes(7), environ(7)
Oracle Solaris 11.4 14 Mar 2016 gettxt(3C)