svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
getpagesizes(3c)
Standard C Library Functions getpagesizes(3C)
NAME
getpagesizes - get system supported page sizes
SYNOPSIS
#include <sys/mman.h>
int getpagesizes(size_t pagesize[], int nelem);
DESCRIPTION
The getpagesizes() function returns either the number of different page
sizes supported by the system or the actual sizes themselves. When
called with nelem as 0 and pagesize as NULL, getpagesizes() returns the
number of supported page sizes. Otherwise, up to nelem page sizes are
retrieved and assigned to successive elements of pagesize[]. The return
value is the number of page sizes retrieved and set in pagesize[].
Note that if the getpagesizes() function is called from a 32bit pro‐
gram, then the page sizes 4G or above will not be returned. To get
information on larger page sizes, It is recommended to use a 64bit pro‐
gram.
RETURN VALUES
Upon successful completion, the number of pagesizes supported or actu‐
ally retrieved is returned. Otherwise, −1 is returned and errno is set
to indicate the error.
ERRORS
The getpagesizes() function will fail if:
EINVAL The nelem argument is less than 0 or pagesize is NULL but
nelem is non-zero.
USAGE
The getpagesizes() function returns all the page sizes for which the
hardware and system software provide support for the memcntl(2) command
MC_HAT_ADVISE. Not all processors support all page sizes or combina‐
tions of page sizes with equal efficiency. Applications programmers
should take this into consideration when using getpagesizes().
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe
SEE ALSO
memcntl(2), mmap(2), getpagesize(3C), attributes(7)
Oracle Solaris 11.4 23 May 2016 getpagesizes(3C)