svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
fwrite(3c)
Standard C Library Functions fwrite(3C)
NAME
fwrite - binary output
SYNOPSIS
#include <stdio.h>
size_t fwrite(const void *ptr, size_t size, size_t nitems, FILE *stream);
DESCRIPTION
The fwrite() function writes, from the array pointed to by ptr, up to
nitems elements whose size is specified by size, to the stream pointed
to by stream. For each object, size calls are made to the fputc(3C)
function, taking the values (in order) from an array of unsigned char
exactly overlaying the object. The file-position indicator for the
stream (if defined) is advanced by the number of bytes successfully
written. If an error occurs, the resulting value of the file-position
indicator for the stream is unspecified.
The st_ctime and st_mtime fields of the file will be marked for update
between the successful execution of fwrite() and the next successful
completion of a call to fflush(3C) or fclose(3C) on the same stream or
a call to exit(2) or abort(3C).
RETURN VALUES
The fwrite() function returns the number of elements successfully writ‐
ten, which might be less than nitems if a write error is encountered.
If size or nitems is 0, fwrite() returns 0 and the state of the stream
remains unchanged. Otherwise, if a write error occurs, the error indi‐
cator for the stream is set and errno is set to indicate the error.
ERRORS
Refer to fputc(3C).
USAGE
Because of possible differences in element length and byte ordering,
files written using fwrite() are application-dependent, and possibly
cannot be read using fread(3C) by a different application or by the
same application on a different processor.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
write(2), fclose(3C), ferror(3C), fopen(3C), fread(3C), getc(3C),
gets(3C), printf(3C), putc(3C), puts(3C), attributes(7), standards(7)
Oracle Solaris 11.4 24 Jul 2002 fwrite(3C)