svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
fopen(3c)
Standard C Library Functions fopen(3C)
NAME
fopen - open a stream
fopen_s - open a stream with additional safety checks
SYNOPSIS
#include <stdio.h>
FILE *fopen(const char *filename, const char *mode);
#define __STDC_WANT_LIB_EXT1__ 1
#include <stdio.h>
errno_t fopen_s(FILE *restrict *restrict streamptr,
const char *restrict filename, const char *restrict mode);
DESCRIPTION
The fopen() function opens the file whose pathname is the string
pointed to by filename, and associates a stream with it.
The argument mode points to a string beginning with one of the follow‐
ing sequences:
r or rb Open file for reading
w or wb Truncate to zero length or create file for writing
a or ab Append; open or create file for writing at end-of-
file
r+ or rb+ or r+b Open file for update (reading and writing)
w+ or wb+ or w+b Truncate to zero length or create file for update
a+ or ab+ or a+b Append; open or create file for update, writing at
end-of-file
The character b has no effect, but is allowed for ISO C standard con‐
formance (see standards(7)). Opening a file with read mode (r as the
first character in the mode argument) fails if the file does not exist
or cannot be read.
Opening a file with exclusive mode (x somewhere after the initial w or
a in the mode argument) fails if the file already exists or cannot be
created.
Opening a file with append mode (a as the first character in the mode
argument) causes all subsequent writes to the file to be forced to the
then current end-of-file, regardless of intervening calls to fseek(3C).
If two separate processes open the same file for append, each process
may write freely to the file without fear of destroying output being
written by the other. The output from the two processes will be inter‐
mixed in the file in the order in which it is written.
When a file is opened with update mode (+ as the second or third char‐
acter in the mode argument), both input and output may be performed on
the associated stream. However, output must not be directly followed by
input without an intervening call to fflush(3C) or to a file position‐
ing function (fseek(3C), fsetpos(3C), or rewind(3C)), and input must
not be directly followed by output without an intervening call to a
file positioning function, unless the input operation encounters end-
of-file.
When opened, a stream is fully buffered if and only if it can be deter‐
mined not to refer to an interactive device. The error and end-of-file
indicators for the stream are cleared.
If mode begins with w or a and the file did not previously exist, upon
successful completion, fopen() function will mark for update the
st_atime, st_ctime and st_mtime fields of the file and the st_ctime and
st_mtime fields of the parent directory.
If mode begins with w and the file did previously exist, upon success‐
ful completion, fopen() will mark for update the st_ctime and st_mtime
fields of the file. The fopen() function will allocate a file descrip‐
tor as open(2) does.
The largest value that can be represented correctly in an object of
type off_t will be established as the offset maximum in the open file
description.
Additional mode characters are supported in this implementation. These
additional characters must appear after r, w, or a.
Specifying e in the mode argument indicates the file is being opened
with the O_CLOEXEC flag. This sets the FD_CLOEXEC for the underlying
file descriptor. For more information, see the open(2) man page.
Specifying f in the mode argument indicates the file is being opened
with the O_CLOFORK flag. This sets the FD_CLOFORK for the underlying
file descriptor. For more information, see the open(2) man page.
Specifying x in the mode argument indicates the file is being opened in
exclusive mode; the file is opened with the O_EXCL flag. For more
information, see the open(2) man page.
The fopen_s() function is part of the bounds checking interfaces speci‐
fied in the C11 standard, Annex K. It is similar to the fopen() func‐
tion, except for a different return type and an additional parameter,
providing extra safety checks in the form of explicit runtime-con‐
straints as defined in the C11 standard. The fopen_s() function pro‐
vides a new mode character, u which may precede any of the previously
defined modes starting with the character w or a. See INCITS/ISO/IEC
9899:2011.
Implementation specific details for fopen_s() include the following:
Files opened for writing are opened with exclusive, (or non-shared),
access. The file permission for the file will prevent other system
users from accessing the file, that is S_IRUSR | S_IWUSR flags if the
file is being created and the first character of the mode string is not
u. For more information, see the chmod(2) man page. If the file is
being created and first character of the mode string is u, the file
shall have the system default file access permissions.
A runtime-constraint violation will be generated if either streamptr,
filename, or mode is a null pointer.
RETURN VALUES
Upon successful completion, fopen() returns a pointer to the object
controlling the stream. Otherwise, a null pointer is returned and errno
is set to indicate the error.
The fopen() function may fail and not set errno if there are no free
stdio streams.
If the fopen_s() function succeeds in opening a file, it returns zero.
Otherwise, a non-zero value is returned if fopen_s() failed to open the
file or if a runtime-constraint violation was encountered.
ERRORS
The fopen() and fopen_s() functions will fail if:
EACCES Search permission is denied on a component of the path
prefix, or the file exists and the permissions speci‐
fied by mode are denied, or the file does not exist and
write permission is denied for the parent directory of
the file to be created.
EINTR A signal was caught during the execution of fopen().
EISDIR The named file is a directory and mode requires write
access.
ELOOP Too many symbolic links were encountered in resolving
filename.
EMFILE There are {OPEN_MAX} file descriptors currently open in
the calling process.
ENAMETOOLONG The length of the filename exceeds PATH_MAX or a path‐
name component is longer than NAME_MAX.
ENFILE The maximum allowable number of files is currently open
in the system.
ENOENT A component of filename does not name an existing file
or filename is an empty string.
ENOSPC The directory or file system that would contain the new
file cannot be expanded, the file does not exist, and
it was to be created.
ENOTDIR A component of the path prefix is not a directory.
ENXIO The named file is a character special or block special
file, and the device associated with this special file
does not exist.
EOVERFLOW The current value of the file position cannot be repre‐
sented correctly in an object of type fpos_t.
EROFS The named file resides on a read-only file system and
mode requires write access.
The fopen() function may fail if:
EINVAL The value of the mode argument is not valid.
EMFILE {FOPEN_MAX} streams are currently open in the calling
process.
{STREAM_MAX} streams are currently open in the calling
process.
ENAMETOOLONG Pathname resolution of a symbolic link produced an
intermediate result whose length exceeds {PATH_MAX}.
ENOMEM Insufficient storage space is available.
ETXTBSY The file is a pure procedure (shared text) file that is
being executed and mode requires write access.
The fopen_s() function will fail if:
EINVAL Null pointer is passed.
USAGE
The fopen() function has a transitional interface for 64-bit file off‐
sets. For more information, see the lf64(7) man page.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSee below _
StandardSee standards(7).
The fopen() function can be used safely in multithreaded applications.
The fopen_s() function cannot be used safely in a multithreaded appli‐
cation due to the runtime constraint handler. For more information, see
the runtime_constraint_handler(3C) man page.
SEE ALSO
fclose(3C), fdopen(3C), fflush(3C), freopen(3C), freopen_s(3C), fset‐
pos(3C), rewind(3C), attributes(7), lf64(7), standards(7), runtime_con‐
straint_handler(3C)
Oracle Solaris 11.4 11 June 2020 fopen(3C)