svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
exit(3c)
Standard C Library Functions exit(3C)
NAME
exit, _exithandle - terminate process
SYNOPSIS
#include <stdlib.h>
void exit(int status);
void _exithandle(void);
DESCRIPTION
The exit() function terminates a process by calling first _exithandle()
and then _exit() (see exit(2)).
The _exithandle() function calls any functions registered through the
atexit(3C) function in the reverse order of their registration. This
action includes executing all finalization code from the .fini sections
of all objects that are part of the process.
The _exithandle() function is intended for use only with _exit(), and
allows for specialized processing such as dldump(3C) to be performed.
Normal process execution should not be continued after a call to
_exithandle() has occurred, as internal data structures may have been
torn down due to atexit() or .fini processing.
The symbols EXIT_SUCCESS and EXIT_FAILURE are defined in the header
<stdlib.h> and may be used as the value of status to indicate success‐
ful or unsuccessful termination, respectively.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelSafe
SEE ALSO
exit(2), atexit(3C), dldump(3C), attributes(7), standards(7)
Oracle Solaris 11.4 1 Mar 2004 exit(3C)