svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
dlclose(3c)
Standard C Library Functions dlclose(3C)
NAME
dlclose - close a shared object
SYNOPSIS
#include <dlfcn.h>
int dlclose(void *handle);
DESCRIPTION
The dlclose() function decrements the reference count of the supplied
handle. This handle represents an executable object file and its depen‐
dencies, acquired from a previous call to dlopen(). A handle that is no
longer referenced is processed in an attempt to unload any objects that
are associated with the handle from the current process. An unrefer‐
enced handle is no longer available to dlsym().
Any finalization code within an object is executed prior to that object
being unloaded. Any routines registered by an object using atexit(3C)
are called prior to that object being unloaded. See NOTES.
RETURN VALUES
If the handle was successfully unreferenced, dlclose() returns 0. If
the handle is invalid, or an error occurred as a result of unloading an
object, dlclose() returns a non-zero value. Additional diagnostic
information is available through dlerror().
USAGE
The dlclose() function is one of a family of functions that give the
user direct access to the dynamic linking facilities. These facilities
are available to dynamically-linked processes only. See the Oracle
Solaris 11.4 Linkers and Libraries Guide.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
dldump(3C), ld(1), ld.so.1(1), atexit(3C), dladdr(3C), dlerror(3C),
dlopen(3C), dlsym(3C), attributes(7), standards(7)
Oracle Solaris 11.4 Linkers and Libraries Guide
NOTES
A successful invocation of dlclose() does not guarantee that the
objects associated with the handle are removed from the address space
of the current process. Objects can be referenced by multiple handles,
or by other objects. An object is not removed from the address space of
the current process until all references to that object are removed.
Once an object has been closed by dlclose(), referencing symbols con‐
tained in that object can cause undefined behavior.
As part of unloading an object, finalization code within the object is
called before the dlclose() returns. This finalization is user code,
and as such, can produce errors that can not be caught by dlclose().
For example, an object loaded using RTLD_LAZY that attempts to call a
function that can not be located, results in process termination. Erro‐
neous programming practices within the finalization code can also
result in process termination. The runtime linkers debugging facility
can offer help identifying these types of error. See the LD_DEBUG envi‐
ronment variable of ld.so.1(1).
Oracle Solaris 11.4 23 April 2014 dlclose(3C)