svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
clock_getcpuclockid(3c)
Standard C Library Functions clock_getcpuclockid(3C)
NAME
clock_getcpuclockid - access a process CPU-time clock
SYNOPSIS
#include <time.h>
int clock_getcpuclockid(pid_t pid, clockid_t *clock_id);
DESCRIPTION
The clock_getcpuclockid() function shall return the clock ID of the
CPU-time clock of the process specified by pid. If the process
described by pid exists and the calling process has permission, the
clock ID of this clock shall be returned in clock_id. If pid is zero,
the clock_getcpuclockid() function shall return the clock ID of the
CPU-time clock of the process making the call in clock_id. The condi‐
tions under which one process has permission to obtain the CPU-time
clock ID of other processes are implementation-defined.
RETURN VALUES
On successful completion, clock_getcpuclockid() shall return 0; other‐
wise an error shall be returned to indicate the error
ERRORS
The clock_getcpuclockid() function will fail if:
EPERM The requesting process does not have permission to access the
CPU-time clock for the process.
The clock_getcpuclockid() function may fail if:
ESRCH No process can be found corresponding to the process specified
by pid.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
clock_getres(3C), timer_create(3C), attributes(7), standards(7)
Oracle Solaris 11.4 17 Jan 2019 clock_getcpuclockid(3C)