svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
umask(2)
umask(2) System Calls umask(2)
NAME
umask - set and get file creation mask
SYNOPSIS
#include <sys/types.h>
#include <sys/stat.h>
mode_t umask(mode_t cmask);
DESCRIPTION
The umask() function sets the process's file mode creation mask to
cmask and returns the previous value of the mask. Only the access per‐
mission bits of cmask and the file mode creation mask are used. The
mask is inherited by child processes. See Intro(2) for more information
on masks.
RETURN VALUES
The previous value of the file mode creation mask is returned.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardSee standards(7).
SEE ALSO
mkdir(1), sh(1), chmod(2), creat(2), Intro(2), mknod(2), open(2),
stat.h(3HEAD), attributes(7), standards(7)
Oracle Solaris 11.4 28 Dec 1996 umask(2)