svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
sigpending(2)
sigpending(2) System Calls sigpending(2)
NAME
sigpending - examine signals that are blocked and pending
SYNOPSIS
#include <signal.h>
int sigpending(sigset_t *set);
DESCRIPTION
The sigpending() function retrieves those signals that have been sent
to the calling process but are being blocked from delivery by the call‐
ing process's signal mask. The signals are stored in the space pointed
to by the set argument.
RETURN VALUES
Upon successful completion, 0 is returned. Otherwise, −1 is returned
and errno is set to indicate the error.
ERRORS
The sigpending() function will fail if:
EFAULT The set argument points to an illegal address.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardSee standards(7).
SEE ALSO
sigaction(2), sigprocmask(2), sigsetops(3C), attributes(7), stan‐
dards(7)
Oracle Solaris 11.4 28 Dec 1996 sigpending(2)