svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pause(2)
pause(2) System Calls pause(2)
NAME
pause - suspend process until signal
SYNOPSIS
#include <unistd.h>
int pause(void);
DESCRIPTION
The pause() function suspends the calling process until it receives a
signal. The signal must be one that is not currently set to be ignored
by the calling process.
If the signal causes termination of the calling process, pause() does
not return.
If the signal is caught by the calling process and control is returned
from the signal-catching function (see signal(3C)), the calling process
resumes execution from the point of suspension.
RETURN VALUES
Since pause() suspends thread execution indefinitely unless interrupted
by a signal, there is no successful completion return value. If inter‐
rupted, it returns −1 and sets errno to indicate the error.
ERRORS
The pause() function will fail if:
EINTR A signal is caught by the calling process and control is
returned from the signal-catching function.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardSee standards(7).
SEE ALSO
alarm(2), kill(2), signal(3C), wait(3C), attributes(7), standards(7)
Oracle Solaris 11.4 28 Dec 1996 pause(2)