svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
regcmp(1)
regcmp(1) User Commands regcmp(1)
NAME
regcmp - regular expression compile
SYNOPSIS
regcmp [-] filename...
DESCRIPTION
The regcmp command performs a function similar to regcmp and, in most
cases, precludes the need for calling regcmp from C programs. Bypassing
regcmp saves on both execution time and program size. The command
regcmp compiles the regular expressions in filename and places the out‐
put in filename.i.
OPTIONS
− If the − option is used, the output is placed in filename.c.
The format of entries in filename is a name (C variable) fol‐
lowed by one or more blanks followed by one or more regular
expressions enclosed in double quotes. The output of regcmp is
C source code. Compiled regular expressions are represented as
extern char vectors. filename.i files may thus be #included in
C programs, or filename.c files may be compiled and later
loaded. In the C program that uses the regcmp output,
regex(abc,line) applies the regular expression named abc to
line. Diagnostics are self-explanatory.
EXAMPLES
Example 1 Using the regcmp command.
name "([A−Za−z][A−Za−z0−9_]*)$0"
telno "\({0,1}([2−9][01][1−9])$0\){0,1} *"
"([2−9][0−9]{2})$1[ −]{0,1}"
"([0−9]{4})$2"
The three arguments to telno shown above must all be entered on one
line.
In the C program that uses the regcmp output,
regex(telno, line, area, exch, rest)
applies the regular expression named telno to line.
ENVIRONMENT VARIABLES
A general description of the usage of the LC_* environmental variables
can be found in environ(7).
LC_CTYPE Determines how regcmp handles characters. When LC_CTYPE
is set to a valid value, regcmp can display and handle
text and filenames containing valid characters for that
locale.
LC_MESSAGES Determines how diagnostic and informative messages are
presented. This includes the language and style of the
messages, and the correct form of affirmative and nega‐
tive responses. In the "C" locale, the messages are pre‐
sented in the default form found in the program itself
(in most cases, U.S. English).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Availabilitydeveloper/base-developer-utilities _ CSIEn‐
abled
SEE ALSO
regcmp(3C), attributes(7), environ(7)
Oracle Solaris 11.4 8 Jun 2011 regcmp(1)