svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
egrep(1)
egrep(1) User Commands egrep(1)
NAME
egrep - search a file for a pattern using full regular expressions
SYNOPSIS
/usr/bin/egrep [-bchilnsv] -e pattern_list [file...]
/usr/bin/egrep [-bchilnsv] -f file [file...]
/usr/bin/egrep [-bchilnsv] pattern [file...]
/usr/xpg4/bin/egrep [-bchilnqsvx] -e pattern_list [-f file]
[file...]
/usr/xpg4/bin/egrep [-bchilnqsvx] [-e pattern_list] -f file
[file...]
/usr/xpg4/bin/egrep [-bchilnqsvx] pattern [file...]
DESCRIPTION
The egrep (expression grep) utility searches files for a pattern of
characters and prints all lines that contain that pattern. egrep uses
full regular expressions (expressions that have string values that use
the full set of alphanumeric and special characters) to match the pat‐
terns. It uses a fast deterministic algorithm that sometimes needs
exponential space.
If no files are specified, egrep assumes standard input. Normally, each
line found is copied to the standard output. The file name is printed
before each line found if there is more than one input file.
/usr/bin/egrep
The /usr/bin/egrep utility accepts full regular expressions as
described on the regexp(7) manual page, except for \( and \), \( and
\), \{ and \}, \< and \>, and \n, and with the addition of:
1. A full regular expression followed by + that matches one or
more occurrences of the full regular expression.
2. A full regular expression followed by ? that matches 0 or 1
occurrences of the full regular expression.
3. Full regular expressions separated by | or by a NEWLINE that
match strings that are matched by any of the expressions.
4. A full regular expression that can be enclosed in parenthe‐
ses ()for grouping.
Be careful using the characters $, *, [, ^, |, (, ), and \ in full reg‐
ular expression, because they are also meaningful to the shell. It is
safest to enclose the entire full regular expression in single quotes
(´´).
The order of precedence of operators is [], then *?+, then concatena‐
tion, then | and NEWLINE.
/usr/xpg4/bin/egrep
The /usr/xpg4/bin/egrep utility uses the regular expressions described
in the EXTENDED REGULAR EXPRESSIONS section of the regex(7) manual
page.
OPTIONS
The following options are supported for both /usr/bin/egrep and
/usr/xpg4/bin/egrep:
-b Precede each line by the block number on which it
was found. This can be useful in locating block num‐
bers by context (first block is 0).
-c Print only a count of the lines that contain the
pattern.
-e pattern_list Search for a pattern_list (full regular expression
that begins with a −).
-f file Take the list of full regular expressions from
file.
-h Suppress printing of filenames when searching multi‐
ple files.
-i Ignore upper/lower case distinction during compar‐
isons.
-l Print the names of files with matching lines once,
separated by NEWLINEs. Does not repeat the names of
files when the pattern is found more than once.
-n Precede each line by its line number in the file
(first line is 1).
-s Work silently, that is, display nothing except error
messages. This is useful for checking the error sta‐
tus.
-v Print all lines except those that contain the pat‐
tern.
/usr/xpg4/bin/egrep
The following options are supported for /usr/xpg4/bin/egrep only:
-q Quiet. Does not write anything to the standard output, regardless
of matching lines. Exits with zero status if an input line is
selected.
-x Consider only input lines that use all characters in the line to
match an entire fixed string or regular expression to be matching
lines.
OPERANDS
The following operands are supported:
file A path name of a file to be searched for the patterns. If no
file operands are specified, the standard input is used.
/usr/bin/egrep
pattern Specify a pattern to be used during the search for input.
/usr/xpg4/bin/egrep
pattern Specify one or more patterns to be used during the search
for input. This operand is treated as if it were specified
as -epattern_list..
ENVIRONMENT VARIABLES
See environ(7) for descriptions of the following environment variables
that affect the execution of egrep: LC_COLLATE, LC_CTYPE, LC_MESSAGES,
and NLSPATH.
EXIT STATUS
The following exit values are returned:
0 If any matches are found.
1 If no matches are found.
2 For syntax errors or inaccessible files (even if matches were
found).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
/usr/bin/egrep
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Availabilitysystem/core-os _ CSINot Enabled
/usr/xpg4/bin/egrep
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Availabilitysystem/xopen/xcu4 _ CSIEnabled
SEE ALSO
fgrep(1), grep(1), sed(1), sh(1), XPG4(7), attributes(7), environ(7),
regex(7), regexp(7)
NOTES
Ideally there should be only one grep command, but there is not a sin‐
gle algorithm that spans a wide enough range of space-time trade-offs.
Lines are limited only by the size of the available virtual memory.
/usr/xpg4/bin/egrep
The /usr/xpg4/bin/egrep utility is identical to /usr/xpg4/bin/grep -E.
See grep(1). Portable applications should use /usr/xpg4/bin/grep -E.
Oracle Solaris 11.4 4 Feb 2015 egrep(1)