svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
ualarm(3c)
Standard C Library Functions ualarm(3C)
NAME
ualarm - schedule signal after interval in microseconds
SYNOPSIS
#include <unistd.h>
useconds_t ualarm(useconds_t useconds, useconds_t interval);
DESCRIPTION
The ualarm() function causes the SIGALRM signal to be generated for the
calling process after the number of real-time microseconds specified by
the useconds argument has elapsed. When the interval argument is non-
zero, repeated timeout notification occurs with a period in microsec‐
onds specified by the interval argument. If the notification signal,
SIGALRM, is not caught or ignored, the calling process is terminated.
Because of scheduling delays, resumption of execution when the signal
is caught may be delayed an arbitrary amount of time.
Interactions between ualarm() and either alarm(2) or sleep(3C) are
unspecified.
RETURN VALUES
The ualarm() function returns the number of microseconds remaining from
the previous ualarm() call. If no timeouts are pending or if ualarm()
has not previously been called, ualarm() returns 0.
ERRORS
No errors are defined.
USAGE
The ualarm() function is a simplified interface to setitimer(2), and
uses the ITIMER_REAL interval timer.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ StandardSee stan‐
dards(7).
SEE ALSO
alarm(2), setitimer(2), sleep(3C), sighold(3C), signal(3C), usleep(3C),
attributes(7), standards(7)
Oracle Solaris 11.4 14 Aug 2002 ualarm(3C)