svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
t_unbind(3c)
Standard C Library Functions t_unbind(3C)
NAME
t_unbind - disable a transport endpoint
SYNOPSIS
#include <xti.h>
int t_unbind(int fd);
DESCRIPTION
The This routine is part of the XTI interfaces which evolved from the
TLI interfaces. XTI represents the future evolution of these inter‐
faces. However, TLI interfaces are supported for compatibility. When
using a TLI routine that has the same name as an XTI routine, the
tiuser.h header file must be used. Refer to the TLI COMPATIBILITY sec‐
tion for a description of differences between the two interfaces.
t_unbind() function disables the transport endpoint specified by fd
which was previously bound by t_bind(3C). On completion of this call,
no further data or events destined for this transport endpoint will be
accepted by the transport provider. An endpoint which is disabled by
using t_unbind() can be enabled by a subsequent call to t_bind(3C).
RETURN VALUES
Upon successful completion, a value of 0 is returned. Otherwise, a
value of -1 is returned and t_errno is set to indicate an error.
VALID STATES
T_IDLE.
ERRORS
On failure, t_errno is set to one of the following:
TBADF The specified file descriptor does not refer to a trans‐
port endpoint.
TLOOK An asynchronous event has occurred on this transport end‐
point.
TOUTSTATE The communications endpoint referenced by fd is not in one
of the states in which a call to this function is valid.
TPROTO This error indicates that a communication problem has been
detected between XTI and the transport provider for which
there is no other suitable XTI error (t_errno).
TSYSERR A system error has occurred during execution of this func‐
tion.
TLI COMPATIBILITY
The XTI and TLI interface definitions have common names but use differ‐
ent header files. This, and other semantic differences between the two
interfaces are described in the subsections below.
Interface Header
The XTI interfaces use the header file, xti.h . TLI interfaces should
not use this header. They should use the header:
#include <tiuser.h>
Error Description Values
The t_errno value that can be set by the XTI interface and cannot be
set by the TLI interface is:
TPROTO
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe
SEE ALSO
t_bind(3C), attributes(7)
Oracle Solaris 11.4 7 May 1998 t_unbind(3C)