svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
t_snddis(3c)
Standard C Library Functions t_snddis(3C)
NAME
t_snddis - send user-initiated disconnection request
SYNOPSIS
#include <xti.h>
int t_snddis(int fd, const struct t_call *call);
DESCRIPTION
This routine is part of the XTI interfaces which evolved from the TLI
interfaces. XTI represents the future evolution of these interfaces.
However, TLI interfaces are supported for compatibility. When using a
TLI routine that has the same name as an XTI routine, the tiuser.h
header file must be used. Refer to the TLI COMPATIBILITY section for a
description of differences between the two interfaces.
This function is used to initiate an abortive release on an already
established connection, or to reject a connection request. The argument
fd identifies the local transport endpoint of the connection, and call
specifies information associated with the abortive release. The argu‐
ment call points to a t_call structure which contains the following
members:
struct netbuf addr;
struct netbuf opt;
struct netbuf udata;
int sequence;
The values in call have different semantics, depending on the context
of the call to t_snddis(). When rejecting a connection request, call
must be non-null and contain a valid value of sequence to uniquely
identify the rejected connection indication to the transport provider.
The sequence field is only meaningful if the transport connection is in
the T_INCON state. The addr and opt fields of call are ignored. In all
other cases, call need only be used when data is being sent with the
disconnection request. The addr, opt and sequence fields of the t_call
structure are ignored. If the user does not wish to send data to the
remote user, the value of call may be a null pointer.
The udata structure specifies the user data to be sent to the remote
user. The amount of user data must not exceed the limits supported by
the transport provider, as returned in the discon field, of the info
argument of t_open(3C) or t_getinfo(3C). If the len field of udata is
zero, no data will be sent to the remote user.
RETURN VALUES
Upon successful completion, a value of 0 is returned. Otherwise, a
value of -1 is returned and t_errno is set to indicate an error.
VALID STATES
T_DATAXFER, T_OUTCON, T_OUTREL, T_INREL, T_INCON(ocnt > 0).
ERRORS
On failure, t_errno is set to one of the following:
TBADF The specified file descriptor does not refer to a trans‐
port endpoint.
TBADDATA The amount of user data specified was not within the
bounds allowed by the transport provider.
TBADSEQ An invalid sequence number was specified, or a null call
pointer was specified, when rejecting a connection
request.
TLOOK An asynchronous event, which requires attention, has
occurred.
TNOTSUPPORT This function is not supported by the underlying trans‐
port provider.
TOUTSTATE The communications endpoint referenced by fd is not in
one of the states in which a call to this function is
valid.
TPROTO This error indicates that a communication problem has
been detected between XTI and the transport provider for
which there is no other suitable XTI error (t_errno).
TSYSERR A system error has occurred during execution of this
function.
TLI COMPATIBILITY
The XTI and TLI interface definitions have common names but use differ‐
ent header files. This, and other semantic differences between the two
interfaces are described in the subsections below.
Interface Header
The XTI interfaces use the header file, xti.h. TLI interfaces should
not use this header. They should use the header:
#include <tiuser.h>
Error Description Values
The t_errno value TPROTO can be set by the XTI interface but not by the
TLI interface.
Option Buffers
The format of the options in an opt buffer is dictated by the transport
provider. Unlike the XTI interface, the TLI interface does not fix the
buffer format.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT LevelSafe
SEE ALSO
t_snd(3C), t_connect(3C), t_getinfo(3C), t_listen(3C), t_open(3C),
attributes(7)
WARNINGS
t_snddis() is an abortive disconnection. Therefore a t_snddis() issued
on a connection endpoint may cause data previously sent by means of
t_snd(3C), or data not yet received, to be lost, even if an error is
returned.
Oracle Solaris 11.4 7 May 1998 t_snddis(3C)