svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
t_rcvdis(3c)
Standard C Library Functions t_rcvdis(3C)
NAME
t_rcvdis - retrieve information from disconnection
SYNOPSIS
#include <xti.h>
int t_rcvdis(int fd, struct t_discon *discon);
DESCRIPTION
This routine is part of the XTI interfaces which evolved from the TLI
interfaces. XTI represents the future evolution of these interfaces.
However, TLI interfaces are supported for compatibility. When using a
TLI routine that has the same name as an XTI routine, the tiuser.h
header file must be used. Refer to the TLI COMPATIBILITY section for a
description of differences between the two interfaces.
This function is used to identify the cause of a disconnection and to
retrieve any user data sent with the disconnection. The argument fd
identifies the local transport endpoint where the connection existed,
and discon points to a t_discon structure containing the following mem‐
bers:
struct netbuf udata;
int reason;
int sequence;
The field reason specifies the reason for the disconnection through a
protocol-dependent reason code, udata identifies any user data that was
sent with the disconnection, and sequence may identify an outstanding
connection indication with which the disconnection is associated. The
field sequence is only meaningful when t_rcvdis() is issued by a pas‐
sive transport user who has executed one or more t_listen(3C) functions
and is processing the resulting connection indications. If a disconnec‐
tion indication occurs, sequence can be used to identify which of the
outstanding connection indications is associated with the disconnec‐
tion.
The maxlen field of udata may be set to zero, if the user does not care
about incoming data. If, in addition, the user does not need to know
the value of reason or sequence, discon may be set to NULL and any user
data associated with the disconnection indication shall be discarded.
However, if a user has retrieved more than one outstanding connection
indication by means of t_listen(3C), and discon is a null pointer, the
user will be unable to identify with which connection indication the
disconnection is associated.
RETURN VALUES
Upon successful completion, a value of 0 is returned. Otherwise, a
value of -1 is returned and t_errno is set to indicate an error.
VALID STATES
T_DATAXFER, T_OUTCON, T_OUTREL, T_INREL, T_INCON(ocnt > 0).
ERRORS
On failure, t_errno is set to one of the following:
TBADF The specified file descriptor does not refer to a trans‐
port endpoint.
TBUFOVFLW The number of bytes allocated for incoming data (maxlen)
is greater than 0 but not sufficient to store the data.
If fd is a passive endpoint with ocnt > 1, it remains in
state T_INCON; otherwise, the endpoint state is set to
T_IDLE.
TNODIS No disconnection indication currently exists on the
specified transport endpoint.
TNOTSUPPORT This function is not supported by the underlying trans‐
port provider.
TOUTSTATE The communications endpoint referenced by fd is not in
one of the states in which a call to this function is
valid.
TPROTO This error indicates that a communication problem has
been detected between XTI and the transport provider for
which there is no other suitable XTI error (t_errno).
TSYSERR A system error has occurred during execution of this
function.
TLI COMPATIBILITY
The XTI and TLI interface definitions have common names but use differ‐
ent header files. This, and other semantic differences between the two
interfaces are described in the subsections below.
Interface Header
The XTI interfaces use the header file, xti.h. TLI interfaces should
not use this header. They should use the header:
#include <tiuser.h>
Error Description Values
The t_errno values TPROTO and TOUTSTATE can be set by the XTI interface
but not by the TLI interface.
A failure return, and a t_errno value that this routine can set under
different circumstances than its XTI counterpart is TBUFOVFLW. It can
be returned even when the maxlen field of the corresponding buffer has
been set to zero.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT LevelSafe
SEE ALSO
t_alloc(3C), t_connect(3C), t_listen(3C), t_open(3C), t_snddis(3C),
attributes(7)
Oracle Solaris 11.4 7 May 1998 t_rcvdis(3C)