svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
t_look(3c)
Standard C Library Functions t_look(3C)
NAME
t_look - look at the current event on a transport endpoint
SYNOPSIS
#include <xti.h>
int t_look(int fd);
DESCRIPTION
This routine is part of the XTI interfaces which evolved from the TLI
interfaces. XTI represents the future evolution of these interfaces.
However, TLI interfaces are supported for compatibility. When using a
TLI routine that has the same name as an XTI routine, the tiuser.h
header file must be used. Refer to the TLI COMPATIBILITY section for a
description of differences between the two interfaces.
This function returns the current event on the transport endpoint spec‐
ified by fd. This function enables a transport provider to notify a
transport user of an asynchronous event when the user is calling func‐
tions in synchronous mode. Certain events require immediate notifica‐
tion of the user and are indicated by a specific error, TLOOK, on the
current or next function to be executed.
This function also enables a transport user to poll a transport end‐
point periodically for asynchronous events.
RETURN VALUES
Upon success, t_look() returns a value that indicates which of the
allowable events has occurred, or returns zero if no event exists. One
of the following events is returned:
T_LISTEN Connection indication received.
T_CONNECT Connect confirmation received.
T_DATA Normal data received.
T_EXDATA Expedited data received.
T_DISCONNECT Disconnection received.
T_UDERR Datagram error indication.
T_ORDREL Orderly release indication.
T_GODATA Flow control restrictions on normal data flow that led
to a TFLOW error have been lifted. Normal data may be
sent again.
T_GOEXDATA Flow control restrictions on expedited data flow that
led to a TFLOW error have been lifted. Expedited data
may be sent again.
On failure, -1 is returned and t_errno is set to indicate the error.
VALID STATES
ALL - apart from T_UNINIT.
ERRORS
On failure, t_errno is set to one of the following:
TBADF The specified file descriptor does not refer to a transport
endpoint.
TPROTO This error indicates that a communication problem has been
detected between XTI and the transport provider for which
there is no other suitable XTI error (t_errno).
TSYSERR A system error has occurred during execution of this func‐
tion.
TLI COMPATIBILITY
The XTI and TLI interface definitions have common names but use differ‐
ent header files. This, and other semantic differences between the two
interfaces are described in the subsections below.
Interface Header
The XTI interfaces use the header file, xti.h. TLI interfaces should
not use this header. They should use the header:
#include <tiuser.h>
Return Values
The return values that are defined by the XTI interface and cannot be
returned by the TLI interface are:
T_GODATA
T_GOEXDATA
Error Description Values
The t_errno value that can be set by the XTI interface and cannot be
set by the TLI interface is:
TPROTO
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT LevelSafe
SEE ALSO
t_open(3C), t_snd(3C), t_sndudata(3C), attributes(7)
Oracle Solaris 11.4 7 May 1998 t_look(3C)