svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
t_free(3c)
Standard C Library Functions t_free(3C)
NAME
t_free - free a library structure
SYNOPSIS
#include <xti.h>
int t_free(void *ptr, int struct_type);
DESCRIPTION
This routine is part of the XTI interfaces which evolved from the TLI
interfaces. XTI represents the future evolution of these interfaces.
However, TLI interfaces are supported for compatibility. When using a
TLI routine that has the same name as an XTI routine, the tiuser.h
header file must be used. Refer to the TLI COMPATIBILITY section for a
description of differences between the two interfaces.
The t_free() function frees memory previously allocated by t_alloc(3C).
This function will free memory for the specified structure, and will
also free memory for buffers referenced by the structure.
The argument ptr points to one of the seven structure types described
for t_alloc(3C), and struct_type identifies the type of that structure
which must be one of the following:
T_BIND struct t_bind
T_CALL struct t_call
T_OPTMGMT struct t_optmgmt
T_DIS struct t_discon
T_UNITDATA struct t_unitdata
T_UDERROR struct t_uderr
T_INFO struct t_info
where each of these structures is used as an argument to one or more
transport functions.
The function t_free() will check the addr, opt and udata fields of the
given structure, as appropriate, and free the buffers pointed to by the
buf field of the netbuf structure. If buf is a null pointer, t_free()
will not attempt to free memory. After all buffers are freed, t_free()
will free the memory associated with the structure pointed to by ptr.
Undefined results will occur if ptr or any of the buf pointers points
to a block of memory that was not previously allocated by t_alloc(3C).
RETURN VALUES
Upon successful completion, a value of 0 is returned. Otherwise, a
value of -1 is returned and t_errno is set to indicate an error.
VALID STATES
ALL - apart from T_UNINIT.
ERRORS
On failure, t_errno is set to the following:
TNOSTRUCTYPE Unsupported struct_type requested.
TPROTO This error indicates that a communication problem has
been detected between XTI and the transport provider
for which there is no other suitable XTI error
(t_errno).
TSYSERR A system error has occurred during execution of this
function.
TLI COMPATIBILITY
The XTI and TLI interface definitions have common names but use differ‐
ent header files. This, and other semantic differences between the two
interfaces are described in the subsections below.
Interface Header
The XTI interfaces use the header file, xti.h. TLI interfaces should
not use this header. They should use the header:
#include <tiuser.h>
Error Description Values
The t_errno value that can be set by the XTI interface and cannot be
set by the TLI interface is:
TPROTO
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT LevelSafe
SEE ALSO
t_alloc(3C), attributes(7)
Oracle Solaris 11.4 7 May 1998 t_free(3C)