svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
t_errno(3c)
Standard C Library Functions t_errno(3C)
NAME
t_errno - XTI error return value
SYNOPSIS
#include <xti.h>
DESCRIPTION
This error return value is part of the XTI interfaces that evolved from
the TLI interfaces. XTI represents the future evolution of these inter‐
faces. However, TLI interfaces are supported for compatibility. When
using a TLI interface that has the same name as an XTI interface, a
different headerfile, <tiuser.h>, must be used. Refer to the TLI COM‐
PATIBILITY section for a description of differences between the two
interfaces.
t_errno is used by XTI functions to return error values.
XTI functions provide an error number in t_errno which has type int and
is defined in <xti.h>. The value of t_errno will be defined only after
a call to a XTI function for which it is explicitly stated to be set
and until it is changed by the next XTI function call. The value of
t_errno should only be examined when it is indicated to be valid by a
function's return value. Programs should obtain the definition of
t_errno by the inclusion of <xti.h>. The practice of defining t_errno
in program as extern int t_errno is obsolescent. No XTI function sets
t_errno to 0 to indicate an error.
It is unspecified whether t_errno is a macro or an identifier with
external linkage. It represents a modifiable lvalue of type int. If a
macro definition is suppressed in order to access an actual object or a
program defines an identifier with name t_errno, the behavior is unde‐
fined.
The symbolic values stored in t_errno by an XTI function are defined in
the ERRORS sections in all relevant XTI function definition pages.
TLI COMPATIBILITY
t_errno is also used by TLI functions to return error values.
The XTI and TLI interface definitions have common names but use differ‐
ent header files. This, and other semantic differences between the two
interfaces are described in the subsections below.
Interface Header
The XTI interfaces use the header file, <xti.h>. TLI interfaces should
not use this header. They should use the header:
#include <tiuser.h>
Error Description Values
The t_errno values that can be set by the XTI interface but cannot be
set by the TLI interface are:
TNOSTRUCTYPE
TBADNAME
TBADQLEN
TADDRBUSY
TINDOUT
TPROVMISMATCH
TRESADDR
TQFULL
TPROTO
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe
SEE ALSO
attributes(7)
Oracle Solaris 11.4 15 Apr 2019 t_errno(3C)