svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
t_close(3c)
Standard C Library Functions t_close(3C)
NAME
t_close - close a transport endpoint
SYNOPSIS
#include <xti.h>
int t_close(int fd);
DESCRIPTION
This routine is part of the XTI interfaces which evolved from the TLI
interfaces. XTI represents the future evolution of these interfaces.
However, TLI interfaces are supported for compatibility. When using a
TLI routine that has the same name as an XTI routine, the tiuser.h
header file must be used. Refer to the TLI COMPATIBILITY section for a
description of differences between the two interfaces.
The t_close() function informs the transport provider that the user is
finished with the transport endpoint specified by fd, and frees any
local library resources associated with the endpoint. In addition,
t_close() closes the file associated with the transport endpoint.
The function t_close() should be called from the T_UNBND state. See
t_getstate(3C). However, this function does not check state informa‐
tion, so it may be called from any state to close a transport endpoint.
If this occurs, the local library resources associated with the end‐
point will be freed automatically. In addition, close(2) will be issued
for that file descriptor; if there are no other descriptors in this
process or in another process which references the communication end‐
point, any connection that may be associated with that endpoint is bro‐
ken. The connection may be terminated in an orderly or abortive manner.
A t_close() issued on a connection endpoint may cause data previously
sent, or data not yet received, to be lost. It is the responsibility of
the transport user to ensure that data is received by the remote peer.
RETURN VALUES
Upon successful completion, a value of 0 is returned. Otherwise, a
value of -1 is returned and t_errno is set to indicate an error.
VALID STATES
T_UNBND
ERRORS
On failure, t_errno is set to the following:
TBADF The specified file descriptor does not refer to a transport
endpoint.
TPROTO This error indicates that a communication problem has been
detected between XTI and the transport provider for which
there is no other suitable XTI error (t_errno).
TSYSERR A system error has occurred during execution of this func‐
tion.
TLI COMPATIBILITY
The XTI and TLI interface definitions have common names but use differ‐
ent header files. This, and other semantic differences between the two
interfaces are described in the subsections below.
Interface Header
The XTI interfaces use the header file, xti.h. TLI interfaces should
not use this header. They should use the header:
#include <tiuser.h>
Error Description Values
The t_errno value that can be set by the XTI interface and cannot be
set by the TLI interface is:
TPROTO
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT LevelSafe
SEE ALSO
close(2), t_getstate(3C), t_open(3C), t_unbind(3C), attributes(7)
Oracle Solaris 11.4 7 May 1998 t_close(3C)