svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
settimeofday(3c)
Standard C Library Functions gettimeofday(3C)
NAME
gettimeofday, settimeofday - get or set the date and time
SYNOPSIS
#include <sys/time.h>
int gettimeofday(struct timeval *tp, void *tzp);
int settimeofday(struct timeval *tp, void *tzp);
DESCRIPTION
The gettimeofday() function gets and the settimeofday() function sets
the system's notion of the current time. The current time is expressed
in elapsed seconds and microseconds since 00:00 Universal Coordinated
Time, January 1, 1970. The resolution of the system clock is hardware
dependent; the time may be updated continuously or in clock ticks.
The tp argument points to a timeval structure, which includes the fol‐
lowing members:
long tv_sec; /* seconds since Jan. 1, 1970 */
long tv_usec; /* and microseconds */
If tp is a null pointer, the current time information is not returned
or set.
The TZ environment variable holds time zone information. For more
information, see the environ(7) man page.
The tzp argument to gettimeofday() and settimeofday() is ignored.
Only privileged processes can set the time of day.
RETURN VALUES
Upon successful completion, 0 is returned. Otherwise, −1 is returned
and errno is set to indicate the error.
ERRORS
The settimeofday() function will fail if:
EINVAL The structure pointed to by tp specifies an invalid time.
EPERM The {PRIV_SYS_TIME} privilege was not asserted in the effec‐
tive set of the calling process.
The gettimeofday() function will fail for 32-bit interfaces if:
EOVERFLOW The system time has progressed beyond 2038, thus the size
of the tv_sec member of the timeval structure pointed to
by tp is insufficient to hold the current time in seconds.
USAGE
If the tv_usec member of tp is > 500000, settimeofday() rounds the sec‐
onds upward. If the time needs to be set with better than one second
accuracy, call settimeofday() for the seconds and then adjtime(2) for
finer accuracy.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface Stabilitygettimeofday() is Standard. _ MT-
LevelMT-Safe
SEE ALSO
adjtime(2), ctime(3C), get_nsec_fromepoch(3C), get_sec_fromepoch(3C),
gethrtime(3C), environ(7), attributes(7), privileges(7), standards(7)
Oracle Solaris 11.4 14 May 2018 gettimeofday(3C)