svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
setpgrp(2)
setpgrp(2) System Calls setpgrp(2)
NAME
setpgrp - set process group ID
SYNOPSIS
#include <sys/types.h>
#include <unistd.h>
pid_t setpgrp(void);
DESCRIPTION
If the calling process is not already a session leader, the setpgrp()
function makes it one by setting its process group ID and session ID to
the value of its process ID, and releases its controlling terminal. See
Intro(2) for more information on process group IDs and session leaders.
RETURN VALUES
The setpgrp() function returns the value of the new process group ID.
ERRORS
No errors are defined.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ StandardSee stan‐
dards(7).
SEE ALSO
setpgrp(1), exec(2), fork(2), getpid(2), getsid(2), Intro(2), kill(2),
signal(3C), attributes(7), standards(7)
Oracle Solaris 11.4 5 Jan 2000 setpgrp(2)