svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
setgroups(2)
getgroups(2) System Calls getgroups(2)
NAME
getgroups, setgroups - get or set supplementary group access list IDs
SYNOPSIS
#include <unistd.h>
int getgroups(int gidsetsize, gid_t *grouplist);
int setgroups(int ngroups, const gid_t *grouplist);
DESCRIPTION
The getgroups() function gets the current supplemental group access
list of the calling process and stores the result in the array of group
IDs specified by grouplist. This array has gidsetsize entries and must
be large enough to contain the entire list. This list cannot be larger
than NGROUPS_MAX. If gidsetsize equals 0, getgroups() will return the
number of groups to which the calling process belongs without modifying
the array pointed to by grouplist.
The setgroups() function sets the supplementary group access list of
the calling process from the array of group IDs specified by grouplist.
The number of entries is specified by ngroups and can not be greater
than NGROUPS_MAX.
RETURN VALUES
Upon successful completion, getgroups() returns the number of supple‐
mentary group IDs set for the calling process and setgroups() returns
0. Otherwise, −1 is returned and errno is set to indicate the error.
ERRORS
The getgroups() and setgroups() functions will fail if:
EFAULT A referenced part of the array pointed to by grouplist is an
illegal address.
The getgroups() function will fail if:
EINVAL The value of gidsetsize is non-zero and less than the number
of supplementary group IDs set for the calling process.
The setgroups() function will fail if:
EINVAL The value of ngroups is greater than {NGROUPS_MAX}.
EPERM The {PRIV_PROC_SETID} privilege is not asserted in the effec‐
tive set of the calling process.
USAGE
Use of the setgroups() function requires the {PRIV_PROC_SETID} privi‐
lege.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardFor getgroups(), see standards(7).
SEE ALSO
groups(1), chown(2), getuid(2), setuid(2), getgrnam(3C), init‐
groups(3C), attributes(7), privileges(7), standards(7)
Oracle Solaris 11.4 12 Nov 2009 getgroups(2)