svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
rpc_svc_err(3c)
Standard C Library Functions rpc_svc_err(3C)
NAME
rpc_svc_err, svcerr_auth, svcerr_decode, svcerr_noproc, svcerr_noprog,
svcerr_progvers, svcerr_systemerr, svcerr_weakauth - library routines
for server-side remote procedure call errors
DESCRIPTION
These routines are part of the RPC library which allows C language pro‐
grams to make procedure calls on other machines across the network.
These routines can be called by the server-side dispatch function if
there is any error in the transaction with the client.
Routines
See rpc(3C) for the definition of the SVCXPRT data structure.
#include <rpc/rpc.h>
void svcerr_auth(const SVCXPRT *xprt, const enum auth_stat why);
Called by a service dispatch routine that refuses to perform a
remote procedure call due to an authentication error.
void svcerr_decode(const SVCXPRT *xprt);
Called by a service dispatch routine that cannot successfully
decode the remote parameters (see svc_getargs() in
rpc_svc_reg(3C)).
void svcerr_noproc(const SVCXPRT *xprt);
Called by a service dispatch routine that does not implement the
procedure number that the caller requests.
void svcerr_noprog(const SVCXPRT *xprt);
Called when the desired program is not registered with the RPC
package. Service implementors usually do not need this routine.
void svcerr_progvers(const SVCXPRT *xprt, const rpcvers_t low_vers,
const rpcvers_t high_vers);
Called when the desired version of a program is not registered with
the RPC package. low_vers is the lowest version number, and
high_vers is the highest version number. Service implementors usu‐
ally do not need this routine.
void svcerr_systemerr(const SVCXPRT *xprt);
Called by a service dispatch routine when it detects a system error
not covered by any particular protocol. For example, if a service
can no longer allocate storage, it may call this routine.
void svcerr_weakauth(const SVCXPRT *xprt);
Called by a service dispatch routine that refuses to perform a
remote procedure call due to insufficient (but correct) authentica‐
tion parameters. The routine calls svcerr_auth(xprt, AUTH_TOOWEAK).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe
SEE ALSO
rpc(3C), rpc_svc_calls(3C), rpc_svc_create(3C), rpc_svc_reg(3C),
attributes(7)
Oracle Solaris 11.4 11 May 2021 rpc_svc_err(3C)