svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
rpc_clnt_auth(3c)
Standard C Library Functions rpc_clnt_auth(3C)
NAME
rpc_clnt_auth, auth_destroy, authnone_create, authsys_create, auth‐
sys_create_default - library routines for client-side remote procedure
call authentication
SYNOPSIS
void auth_destroy(AUTH *auth);
AUTH *authnone_create(void);
AUTH *authsys_create(const cha r*host, const uid_t uid, const gid_t gid,
const int len, const gid_t *aup_gids);
AUTH *authsys_create_default(void);
DESCRIPTION
These routines are part of the RPC library that allows C language pro‐
grams to make procedure calls on other machines across the network,
with desired authentication.
These routines are normally called after creating the CLIENT handle.
The cl_auth field of the CLIENT structure should be initialized by the
AUTH structure returned by some of the following routines. The client's
authentication information is passed to the server when the RPC call is
made.
Only the NULL and the SYS style of authentication is discussed here.
For the DES style authentication, please refer to secure_rpc(3C).
The NULL and SYS style of authentication are safe in multithreaded
applications. For the MT-level of the DES style, see its pages.
Routines
The following routines require that the header <rpc/rpc.h> be included
(see rpc(3C) for the definition of the AUTH data structure).
#include <rpc/rpc.h>
auth_destroy() A function macro that destroys the authenti‐
cation information associated with auth.
Destruction usually involves deallocation of
private data structures. The use of auth is
undefined after calling auth_destroy().
authnone_create() Create and return an RPC authentication han‐
dle that passes nonusable authentication
information with each remote procedure call.
This is the default authentication used by
RPC.
authsys_create() Create and return an RPC authentication han‐
dle that contains AUTH_SYS authentication
information. The parameter host is the name
of the machine on which the information was
created; uid is the user's user ID; gid is
the user's current group ID; len and aup_gids
refer to a counted array of groups to which
the user belongs.
authsys_create_default Call authsys_create() with the appropriate
parameters.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe
SEE ALSO
rpc(3C), rpc_clnt_calls(3C), rpc_clnt_create(3C), secure_rpc(3C),
attributes(7)
Oracle Solaris 11.4 11 May 2021 rpc_clnt_auth(3C)