svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
psiginfo(3c)
Standard C Library Functions psignal(3C)
NAME
psignal, psiginfo - system signal messages
SYNOPSIS
#include <siginfo.h>
void psignal(int sig, const char *s);
void psiginfo(siginfo_t *pinfo, char *s);
DESCRIPTION
The psignal() and psiginfo() functions produce messages on the standard
error output describing a signal. The sig argument is a signal that may
have been passed as the first argument to a signal handler. The pinfo
argument is a pointer to a siginfo structure that may have been passed
as the second argument to an enhanced signal handler. See sigaction(2).
The argument string s is printed first, followed by a colon and a
blank, followed by the message and a NEWLINE character.
USAGE
Messages printed from these functions are in the native language speci‐
fied by the LC_MESSAGES locale category. See setlocale(3C).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelSafe
SEE ALSO
sigaction(2), gettext(3C), perror(3C), setlocale(3C), siginfo.h(3HEAD),
signal.h(3HEAD), attributes(7)
Oracle Solaris 11.4 31 Mar 2005 psignal(3C)