svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
ppoll(2)
poll(2) System Calls poll(2)
NAME
poll, ppoll - input/output multiplexing
SYNOPSIS
#include <poll.h>
int poll(struct pollfd * fds, nfds_t nfds, int timeout);
int ppoll(struct pollfd *restrict fds, nfds_t nfds,
const struct timespec *restrict timeout,
const sigset_t *restrict sigmask);
DESCRIPTION
The poll() function provides applications with a mechanism for multi‐
plexing input/output over a set of file descriptors. For each member of
the array pointed to by fds, poll() examines the given file descriptor
for the event(s) specified in events. The number of pollfd structures
in the fds array is specified by nfds. The poll() function identifies
those file descriptors on which an application can read or write data,
or on which certain events have occurred.
The fds argument specifies the file descriptors to be examined and the
events of interest for each file descriptor. It is a pointer to an
array with one member for each open file descriptor of interest. The
array's members are pollfd structures, which contain the following mem‐
bers:
int fd; /* file descriptor */
short events; /* requested events */
short revents; /* returned events */
The fd member specifies an open file descriptor and the events and
revents members are bitmasks constructed by a logical OR operation of
any combination of the following event flags:
POLLIN Data other than high priority data may be read without
blocking. For streams, this flag is set in revents even
if the message is of zero length.
POLLRDNORM Normal data (priority band equals 0) may be read without
blocking. For streams, this flag is set in revents even
if the message is of zero length.
POLLRDBAND Data from a non-zero priority band may be read without
blocking. For streams, this flag is set in revents even
if the message is of zero length.
POLLPRI High priority data may be received without blocking. For
streams, this flag is set in revents even if the message
is of zero length.
POLLOUT Normal data (priority band equals 0) may be written with‐
out blocking.
POLLWRNORM The same as POLLOUT.
POLLWRBAND Priority data (priority band > 0) may be written. This
event only examines bands that have been written to at
least once.
POLLERR An error has occurred on the device or stream. This flag
is only valid in the revents bitmask; it is not used in
the events member.
POLLHUP A hangup has occurred on the stream. This event and POLL‐
OUT are mutually exclusive; a stream can never be
writable if a hangup has occurred. However, this event
and POLLIN, POLLRDNORM, POLLRDBAND, or POLLPRI are not
mutually exclusive. This flag is only valid in the
revents bitmask; it is not used in the events member.
POLLNVAL The specified fd value does not belong to an open file.
This flag is only valid in the revents member; it is not
used in the events member.
If the value fd is less than 0, events is ignored and revents is set to
0 in that entry on return from poll().
The results of the poll() query are stored in the revents member in the
pollfd structure. Bits are set in the revents bitmask to indicate which
of the requested events are true. If none are true, none of the speci‐
fied bits are set in revents when the poll() call returns. The event
flags POLLHUP, POLLERR, and POLLNVAL are always set in revents if the
conditions they indicate are true; this occurs even though these flags
were not present in events.
If none of the defined events have occurred on any selected file
descriptor, poll() waits at least timeout milliseconds for an event to
occur on any of the selected file descriptors. On a computer where mil‐
lisecond timing accuracy is not available, timeout is rounded up to the
nearest legal value available on that system. If the value timeout is
0, poll() returns immediately. If the value of timeout is −1, poll()
blocks until a requested event occurs or until the call is interrupted.
The poll() function is not affected by the O_NDELAY and O_NONBLOCK
flags.
The poll() function supports regular files, terminal and pseudo-termi‐
nal devices, streams-based files, FIFOs and pipes. The behavior of
poll() on elements of fds that refer to other types of file is unspeci‐
fied.
The poll() function supports sockets.
A file descriptor for a socket that is listening for connections will
indicate that it is ready for reading, once connections are available.
A file descriptor for a socket that is connecting asynchronously will
indicate that it is ready for writing, once a connection has been
established.
Regular files always poll() TRUE for reading and writing.
The relationship between poll() and ppoll() is analogous to the rela‐
tionship between select(3C) and pselect(3C): like pselect(), ppoll()
allows an application to safely wait until either a file descriptor
becomes ready or until a signal is caught.
Other than the difference in the timeout argument, the following
ppoll() call:
ready = ppoll(&fds, nfds, timeout, &sigmask);
is equivalent to atomically executing the following calls:
sigset_t origmask;
sigprocmask(SIG_SETMASK, &sigmask, &origmask);
ready = ppoll(&fds, nfds, timeout);
sigprocmask(SIG_SETMASK, &origmask, NULL);
If sigmask is not a null pointer, then the pselect() function replaces
the signal mask of the process by the set of signals pointed to by sig‐
mask before examining the descriptors, and restores the signal mask of
the process before returning.
The timeout argument specifies an upper limit on the amount of time
that ppoll() will block. This argument is a pointer to a structure of
the following form:
struct timespec {
long tv_sec; /* seconds */
long tv_nsec; /* nanoseconds */
};
If timeout is specified as NULL, ppoll() can block indefinitely.
RETURN VALUES
Upon successful completion, a non-negative value is returned. A posi‐
tive value indicates the total number of file descriptors that has been
selected (that is, file descriptors for which the revents member is
non-zero). A value of 0 indicates that the call timed out and no file
descriptors have been selected. Upon failure, −1 is returned and errno
is set to indicate the error.
ERRORS
The poll() and ppoll() functions will fail if:
EAGAIN Allocation of internal data structures failed, but the
request may be attempted again.
EFAULT Some argument points to an illegal address.
EINTR A signal was caught during the poll() function.
EINVAL The argument nfds is greater than {OPEN_MAX}, or one of the
fd members refers to a stream or multiplexer that is linked
(directly or indirectly) downstream from a multiplexer.
ENOSYS There is no poll() interface for doorfs.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardSee standards(7).
SEE ALSO
getmsg(2), getrlimit(2), Intro(2), putmsg(2), read(2), write(2),
select(3C), attributes(7), standards(7), chpoll(9E)
STREAMS Programming Guide
NOTES
Non-STREAMS drivers use chpoll(9E) to implement poll() on these
devices.
Oracle Solaris 11.4 14 Jan 2019 poll(2)