svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
nscfg(8)
nscfg(8) System Administration Commands nscfg(8)
NAME
nscfg - import, export name service configurations
SYNOPSIS
/usr/sbin/nscfg command [cmd_options] [operands]
/usr/sbin/nscfg import [-fnvq] FMRI]
/usr/sbin/nscfg export [-nvq] FMRI]
/usr/sbin/nscfg unconfig [-nvq] FMRI]
/usr/sbin/nscfg validate [-vq] FMRI]
/usr/sbin/nscfg adldap [-nvqu]
/usr/sbin/nscfg check [-vq] [FMRI]
/usr/sbin/nscfg help
DESCRIPTION
The nscfg utility imports or exports legacy name service configuration
files into or out of the SMF repository. Given a valid SMF configura‐
tion and corresponding FMRI, nscfg will regenerate the legacy naming
service configuration files, such as nsswitch.conf, resolv.conf,
nscd.conf, and so forth, into their legacy locations. Alternatively,
nscfg can import those same configuration files populating the SMF
repository if it is currently unpopulated.
The following are SMF services that can be operands to nscfg. In many
instances, the legacy configuration file that is replaced by the SMF
service is listed.
svc:/system/name-service/switch:default
Legacy file: /etc/nsswitch.conf
Name service switch configuration (used by nscd).
svc:/system/name-service/cache:default
Legacy file: /etc/nscd.conf
Name service cache (nscd).
svc:/network/dns/client:default
Legacy file: /etc/resolv.conf
DNS naming service.
svc:/network/nis/domain:default
Legacy file: /etc/defaultdomain
Legacy file: /var/yp/binding/$DOMAIN/*
Shared NIS domain configuration. Used by all NIS services. Also
(historical) shared use with LDAP naming services. Must be enabled
when using nis/client or ldap/client.
svc:/network/nis/client:default
NIS client naming service (ypbind and related)
svc:/network/ldap/client:default
Legacy file: /var/ldap/*
LDAP client naming service (ldap_cachemgr and related).
svc:/network/nis/server:default
NIS server service (ypserv).
svc:/network/nis/passwd:default
NIS server passwd service (rpc.yppasswd).
svc:/network/nis/xfr:default
NIS server xfr service (ypxfrd)
svc:/network/nis/update:default
NIS server update service (rpc.ypupdated)
SUB-COMMANDS
The nscfg utility supports the subcommands described below. Options are
described in the context of the subcommands.
import [-fnvq] FMRI
If none of the SMF repository properties for the specified FMRI are
currently populated, import the legacy configuration files associ‐
ated with the specified FMRI into the SMF repository.
With -f, force the repopulation of the SMF repository with the
legacy configuration, even if currently populated.
With -v, issue verbose progress messages during the requested oper‐
ation. With -q, issue no error or other messages during the re‐
quested operation.
The -n causes the command to not actually perform any changes, the
legacy files are not imported.
export [-nvq] FMRI
Export the SMF configuration for the specified FMRI to legacy con‐
figuration files. This operation removes any existing affected
legacy file(s) and generates new one(s) using the SMF configura‐
tion.
The -n causes the command to not actually perform any changes, no
legacy files are updated.
unconfig [-nvq] FMRI
Unconfigure the SMF configuration for the specified FMRI. This op‐
eration resets the specified FMRI and any existing legacy file(s)
to their initial unconfigured state.
With -v, issue verbose progress messages during the requested oper‐
ation. With -q, issue no error or other messages during the re‐
quested operation.
The -n causes the command to not actually perform any changes.
validate [-vq] FMRI
Validate the SMF configuration for the specified FMRI. This opera‐
tion checks the current configuration and verifies whether any er‐
rors exist.
With -v, issue verbose progress messages during the requested oper‐
ation. With -q, issue no error or other messages during the re‐
quested operation.
adldap [-nvqu]
Configure LDAP naming services using the domain configuration sup‐
plied by the smbadm join command. This option requires the previous
configuration of the system to use Kerberos and an Active Directory
domain prior to executing this operation. If the system is not
properly configured using the smbadm then an error will be issued
and this operation will not proceed with LDAP naming services con‐
figuration.
Using the active Domain configuration, this operation inspects the
Active Directory LDAP server to verify the required LDAP schema
that can support users and groups for Solaris. Then if all pre-req‐
uisites are met, this operation will configure the system into LDAP
"manual mode" with "proxy" authentication using sasl/GSSAPI (Ker‐
beros) credentials to the LDAP server and the Kerberos host princi‐
pal is used as the credential that connects to the AD LDAP server.
The configuration will include "service search descriptors" and
proper configuration for both the user password and group data‐
bases. The SMF service configuration for the LDAP service svc:/net‐
work/ldap/client:default will be updated and that service will au‐
tomatically be started.
Additionally the name service/switch configuration
svc:/system/name-service/switch:default will be updated and both
the name service switch service and the name service cache service
svc:/system/name-service/cache:default will automatically be
restarted.
With -v, issue verbose progress messages during the requested oper‐
ation. With -q, issue no error or other messages during the re‐
quested operation. With -n, perform all the AD LDAP server inspec‐
tion and pre-requisite checks, but do not change the configuration.
Exit after the checks are performed.
With -u, unconfigure the LDAP client service
svc:/network/ldap/client:default, unconfigure LDAP from the name
switch service svc:/system/name-service/switch:default and restore
the all the switch databases except the host database back to
"files only".
check [-vq] [FMRI]
Check the SMF configuration for the specified FMRI. This operation
inspects the contents of the current configuration of the specified
FMRI for valid syntax and configuration of property values. When
applicable valid cross service dependencies are also inspected. The
command reports any errors that exist to standard output.
With -v, issue verbose progress messages during the requested oper‐
ation. With -q, issue no error or other messages during the re‐
quested operation.
If no FMRI is specified, then this option does a holistic check of
all name service SMF services and all associated configuration
properties reporting any issues it detects.
In general, all naming service components will attempt to start up
and function, even in a diminished capacity if there are configura‐
tion errors. Those components will generally ignore any configura‐
tion that contains errors and fall back to hardwired defaults. For
example, if LDAP lookups are configured, but the
svc:/network/ldap/client service is disabled, then naming service
lookups will still function but LDAP lookups will not be processed.
When this check operation detects this or any other configuration
issue, it will report the problem so that the administrator can ad‐
dress it.
The check command is executed by the
svc:/system/check/name-services SMF service which logs its output
and depending on the exit code may enter into a degraded state as
an indication that there are configuration issues. Administrators
can then evaluate the log and decide on corrective actions. The
service runs after the svc:/milestone/multi-user milestone and upon
any change to name service configuration with an associated SMF
service.
EXAMPLES
Example 1 Importing DNS Client Configuration
The following command imports the DNS client configuration, stored in
resolv.conf, into the SMF repository.
# nscfg import svc:/network/dns/client:default
Example 2 Exporting SMF LDAP Client Configuration
The following command exports the SMF LDAP client configuration to the
legacy configuration files in /var/ldap.
# nscfg export svc:/network/ldap/client:default
Example 3 Resetting Name Service Switch Configuration
The following command resets the name service switch configuration to
its initial unconfigured state. The command generates no output and ex‐
its quietly with status only.
# nscfg unconfig -q svc:/system/name-service/switch:default
Example 4 Validating LDAP Client Configuration
The following command validates the LDAP client configuration for er‐
rors or inconsistencies. The command generates no output and exits qui‐
etly with status only.
# nscfg validate -q svc:/network/ldap/client:default
Example 5 Check all name service Configuration
The following command inspects name service configuration from all name
service SMF services and reports errors and any cross service inconsis‐
tencies that it detects to standard output.
# nscfg check
EXIT STATUS
0
Command successfully executed.
1
An error occurred.
2
Configuration unmodified, no change necessary.
3
No configuration to import.
FILES
o /etc/default/{nss, yppasswd}
o /etc/defaultdomain
o /etc/nscd.conf
o /etc/nsswitch.conf
o /etc/resolv.conf
o /var/ldap/ldap_client_cred
o /var/ldap/ldap_client_file
o /var/yp/binding/{nisdomainname}/ypservers
o /var/yp/NISLDAPmapping
o /var/yp/securenets
o /var/yp/updaters
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Availabilitysystem/core-os _ Interface StabilityUncom‐
mitted
SEE ALSO
svcs(1), defaultdomain(5), nsswitch.conf(5), resolv.conf(5),
ypfiles(5), attributes(7), ldapclient(8), nscd(8), svcadm(8),
svccfg(8), ypinit(8)
HISTORY
Introduced in Oracle Solaris 11.
Support for check added in Oracle Solaris 11.4.90.
Oracle Solaris 11.4 13 Aug 2025 nscfg(8)