svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
msgids(2)
msgids(2) System Calls msgids(2)
NAME
msgids - discover all message queue identifiers
SYNOPSIS
#include <sys/msg.h>
int msgids(int *buf, uint_t nids, uint_t *pnids);
DESCRIPTION
The msgids() function copies all active message queue identifiers from
the system into the user-defined buffer specified by buf, provided that
the number of such identifiers is not greater than the number of inte‐
gers the buffer can contain, as specified by nids. If the size of the
buffer is insufficient to contain all of the active message queue iden‐
tifiers in the system, none are copied.
Whether or not the size of the buffer is sufficient to contain all of
them, the number of active message queue identifiers in the system is
copied into the unsigned integer pointed to by pnids.
If nids is 0 or less than the number of active message queue identi‐
fiers in the system, buf is ignored.
RETURN VALUES
Upon successful completion, msgids() returns 0. Otherwise, −1 is
returned and errno is set to indicate the error.
ERRORS
The msgids() function will fail if:
EFAULT The buf or pnids argument points to an illegal address.
USAGE
The msgids() function returns a snapshot of all the active message
queue identifiers in the system. More may be added and some may be
removed before they can be used by the caller.
EXAMPLES
Example 1 msgids() example
This is sample C code indicating how to use the msgids() function (see
msgsnap(2)):
void
examine_queues(void)
{
int *ids = NULL;
uint_t nids = 0;
uint_t n;
int i;
for (;;) {
if (msgids(ids, nids, &n) != 0) {
perror("msgids");
exit(1);
}
if (n <= nids) /* we got them all */
break;
/* we need a bigger buffer */
ids = reallocarray(ids, n, sizeof (int));
if (ids == NULL) {
perror("reallocarray");
exit(1);
}
nids = n;
}
for (i = 0; i < n; i++)
process_msgid(ids[i]);
free(ids);
}
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe
SEE ALSO
ipcrm(1), ipcs(1), Intro(2), msgctl(2), msgget(2), msgrcv(2),
msgsnap(2), msgsnd(2), attributes(7)
HISTORY
The msgids() function was added to Solaris in the Solaris 8 10/00
(Update 2) release.
Oracle Solaris 11.4 25 Sep 2020 msgids(2)