svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
kstat_data_lookup(3kstat)
Kernel Statistics Library Functions kstat_lookup(3KSTAT)
NAME
kstat_lookup, kstat_data_lookup - find a kstat by name
SYNOPSIS
cc [ flag... ] file... -lkstat [ library...]
#include <kstat.h>
kstat_t *kstat_lookup(kstat_ctl_t *kc, char *ks_module, int ks_instance,
char *ks_name);
void *kstat_data_lookup(kstat_t *ksp, char *name);
DESCRIPTION
The kstat_lookup() function traverses the kstat chain, kc->kc_chain,
searching for a kstat with the same ks_module, ks_instance, and ks_name
fields; this triplet uniquely identifies a kstat. If ks_module is NULL,
ks_instance is -1, or ks_name is NULL, those fields will be ignored in
the search. For example, kstat_lookup(kc, NULL, -1, "foo") will find
the first kstat with name "foo".
The kstat_data_lookup() function searches the kstat's data section for
the record with the specified name. This operation is valid only for
those kstat types that have named data records: KSTAT_TYPE_NAMED and
KSTAT_TYPE_TIMER.
RETURN VALUES
The kstat_lookup() function returns a pointer to the requested kstat if
it is found. Otherwise it returns NULL and sets errno to indicate the
error.
The kstat_data_lookup() function returns a pointer to the requested
data record if it is found. Otherwise it returns NULL and sets errno to
indicate the error .
ERRORS
The kstat_lookup() and kstat_data_lookup() functions will fail if:
EINVAL An attempt was made to look up data for a kstat that was not
of type KSTAT_TYPE_NAMED or KSTAT_TYPE_TIMER.
ENOENT The requested kstat could not be found.
FILES
/dev/kstat kernel statistics driver
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityObsolete _ MT-LevelMT-Safe with
exceptions
The kstat_lookup() function is MT-Safe with the exception that only one
thread may actively use a kstat_ctl_t * value at any time. Synchroniza‐
tion is left to the application.
SEE ALSO
kstat_chain_update(3KSTAT), kstat(3KSTAT), kstat_open(3KSTAT),
kstat_read(3KSTAT), attributes(7), kstat2(3KSTAT2),
kstat2_open(3KSTAT2), kstat2_lookup_map(3KSTAT2),
kstat2_map_get(3KSTAT2)
NOTES
The kstat_lookup() and kstat_data_lookup() functions are deprecated.
They may be removed in a future release of Oracle Solaris. For details
of the new API, see the kstat2(3KSTAT2) man page.
Oracle Solaris 11.4 19 Aug 2016 kstat_lookup(3KSTAT)