svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
getuid(2)
getuid(2) System Calls getuid(2)
NAME
getuid, geteuid, getgid, getegid - get real user, effective user, real
group, and effective group IDs
SYNOPSIS
#include <sys/types.h>
#include <unistd.h>
uid_t getuid(void);
uid_t geteuid(void);
gid_t getgid(void);
gid_t getegid(void);
DESCRIPTION
The getuid() function returns the real user ID of the calling process.
The real user ID identifies the person who is logged in.
The geteuid() function returns the effective user ID of the calling
process. The effective user ID gives the process various permissions
during execution of "set-user-ID" mode processes which use getuid() to
determine the real user ID of the process that invoked them.
The getgid() function returns the real group ID of the calling process.
The getegid() function returns the effective group ID of the calling
process.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardSee standards(7).
SEE ALSO
Intro(2), setuid(2), attributes(7), standards(7)
Oracle Solaris 11.4 28 Dec 1996 getuid(2)