svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
getsid(2)
getsid(2) System Calls getsid(2)
NAME
getsid - get process group ID of session leader
SYNOPSIS
#include <unistd.h>
pid_t getsid(pid_t pid);
DESCRIPTION
The getsid() function obtains the process group ID of the process that
is the session leader of the process specified by pid. If pid is
(pid_t)0, it specifies the calling process.
RETURN VALUES
Upon successful completion, getsid() returns the process group ID of
the session leader of the specified process. Otherwise, it returns
(pid_t)−1 and sets errno to indicate the error.
ERRORS
The getsid() function will fail if:
EPERM The process specified by pid is not in the same session as the
calling process, and the implementation does not allow access
to the process group ID of the session leader of that process
from the calling process.
ESRCH There is no process with a process ID equal to pid.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityStandard
SEE ALSO
exec(2), fork(2), getpgid(2), getpid(2), setpgid(2), setsid(2),
attributes(7), standards(7)
Oracle Solaris 11.4 22 Jan 1996 getsid(2)