svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
fsync(3c)
Standard C Library Functions fsync(3C)
NAME
fsync - synchronize changes to a file
SYNOPSIS
#include <unistd.h>
int fsync(int fildes);
DESCRIPTION
The fsync() function moves all modified data and attributes of the file
descriptor fildes to a storage device. When fsync() returns, all in-
memory modified copies of buffers associated with fildes have been
written to the physical medium. The fsync() function is different from
sync(), which schedules disk I/O for all files but returns before the
I/O completes. The fsync() function forces all outstanding data opera‐
tions to synchronized file integrity completion (see fcntl.h(3HEAD)
definition of O_SYNC.)
The fsync() function forces all currently queued I/O operations associ‐
ated with the file indicated by the file descriptor fildes to the syn‐
chronized I/O completion state. All I/O operations are completed as
defined for synchronized I/O file integrity completion.
RETURN VALUES
Upon successful completion, 0 is returned. Otherwise, −1 is returned
and errno is set to indicate the error. If the fsync() function fails,
outstanding I/O operations are not guaranteed to have been completed.
ERRORS
The fsync() function will fail if:
EBADF The fildes argument is not a valid file descriptor.
EINTR A signal was caught during execution of the fsync() func‐
tion.
EIO An I/O error occurred while reading from or writing to the
file system.
ENOSPC There was no free space remaining on the device containing
the file.
ETIMEDOUT Remote connection timed out. This occurs when the file is
on an NFS file system mounted with the soft option. See
mount_nfs(8).
In the event that any of the queued I/O operations fail, fsync()
returns the error conditions defined for read(2) and write(2).
USAGE
The fsync() function should be used by applications that require that a
file be in a known state. For example, an application that contains a
simple transaction facility might use fsync() to ensure that all
changes to a file or files caused by a given transaction were recorded
on a storage medium.
The manner in which the data reach the physical medium depends on both
implementation and hardware. The fsync() function returns when notified
by the device driver that the write has taken place.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardSee standards(7).
SEE ALSO
read(2), sync(2), write(2), fdatasync(3C), fcntl.h(3HEAD),
attributes(7), standards(7), mount_nfs(8)
Oracle Solaris 11.4 5 Feb 2008 fsync(3C)