svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
fdatasync(3c)
Standard C Library Functions fdatasync(3C)
NAME
fdatasync - synchronize a file's data
SYNOPSIS
#include <unistd.h>
int fdatasync(int fildes);
DESCRIPTION
The fdatasync() function forces all currently queued I/O operations
associated with the file indicated by file descriptor fildes to the
synchronized I/O completion state.
The functionality is as described for fsync(3C) (with the symbol
_XOPEN_REALTIME defined), with the exception that all I/O operations
are completed as defined for synchronised I/O data integrity comple‐
tion.
RETURN VALUES
If successful, the fdatasync() function returns 0. Otherwise, the func‐
tion returns −1 and sets errno to indicate the error. If the fdata‐
sync() function fails, outstanding I/O operations are not guaranteed to
have been completed.
ERRORS
The fdatasync() function will fail if:
EBADF The fildes argument is not a valid file descriptor open for
writing.
EINVAL The system does not support synchronized I/O for this file.
ENOSYS The function fdatasync() is not supported by the system.
In the event that any of the queued I/O operations fail, fdatasync()
returns the error conditions defined for read(2) and write(2).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardSee standards(7).
SEE ALSO
fcntl(2), open(2), read(2), write(2), aio_fsync(3C), fsync(3C),
fcntl.h(3HEAD), attributes(7), standards(7)
Oracle Solaris 11.4 5 Feb 2008 fdatasync(3C)