svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
errno(3c)
Standard C Library Functions perror(3C)
NAME
perror, errno - print system error messages
SYNOPSIS
#include <stdio.h>
void perror(const char *s)
#include <errno.h>
DESCRIPTION
The perror() function produces a message on the standard error output
(file descriptor 2) describing the last error encountered by the thread
during a call to a system or library function. The argument string s is
printed, followed by a colon and a blank, followed by the message and a
NEWLINE character. If s is a null pointer or points to a null string,
the colon is not printed. The argument string should include the name
of the program that incurred the error. The error number is taken from
the errno macro defined in <errno.h>. This per-thread value is set when
errors occur but not cleared when non-erroneous calls are made. See
Intro(2).
USAGE
Messages printed from this function are in the native language speci‐
fied by the LC_MESSAGES locale category. See setlocale(3C).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
Intro(2), fmtmsg(3C), gettext(3C), setlocale(3C), strerror(3C),
attributes(7), standards(7), threads(7)
Oracle Solaris 11.4 19 May 2014 perror(3C)