svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
cat(1)
cat(1) User Commands cat(1)
NAME
cat - concatenate and display files
SYNOPSIS
/usr/bin/cat [-nbsuvet] [file...]
DESCRIPTION
The cat utility reads each file in sequence and writes its contents on
the standard output. Thus:
example% cat file
prints the contents of file on your terminal, and:
example% cat file1 file2 >file3
concatenates file1 and file2, and writes the results in file3. If no
input file is given, cat reads from the standard input stream.
OPTIONS
The following options are supported by /usr/bin/cat:
-b Number the lines, as -n, but omit the line numbers from blank
lines.
-n Precede each line output with its line number.
-s cat is silent about non-existent files.
-u The output is not buffered.
Buffered output is the default.
-v Non-printing characters, with the exception of tabs, NEWLINEs and
form feeds, are printed visibly. ASCII control characters (octal
000 - 037) are printed as ^n, where n is the corresponding ASCII
character in the range octal 100 - 137 (@, A, B, C, . . ., X, Y,
Z, [, \, ], ^, and _); the DEL character (octal 0177) is printed
^?. Other non-printable characters are printed as M-x, where x is
the ASCII character specified by the low-order seven bits.
When used with the -v option, the following options can be used:
-e A $ character is printed at the end of each line, prior to the
NEWLINE.
-t Tabs are printed as ^Is and form feeds to be printed as ^Ls.
The -e and -t options are ignored if the -v option is not specified.
OPERANDS
The following operand is supported:
file A path name of an input file. If no file is specified, the
standard input is used. If file is −, cat reads from the stan‐
dard input at that point in the sequence. cat does not close
and reopen standard input when it is referenced in this way,
but accepts multiple occurrences of − as file.
EXAMPLES
Example 1 Concatenating a File
The following command writes the contents of the file myfile to stan‐
dard output:
example% cat myfile
Example 2 Concatenating Two files into One
The following command concatenates the files doc1 and doc2 and writes
the result to doc.all.
example% cat doc1 doc2 > doc.all
Example 3 Concatenating Two Arbitrary Pieces of Input with a Single
Invocation
When standard input is a terminal, the following command gets two arbi‐
trary pieces of input from the terminal with a single invocation of
cat:
example% cat start - middle - end > file
However, if standard input is a regular file, the above command would
be equivalent to the following command:
example% cat start - middle /dev/null end > file
because the entire contents of the file would be consumed by cat the
first time − was used as a file operand and an end-of-file condition
would be detected immediately when − was referenced the second time.
ENVIRONMENT VARIABLES
See environ(7) for descriptions of the following environment variables
that affect the execution of cat: LANG, LC_ALL, LC_CTYPE, LC_MESSAGES,
and NLSPATH.
EXIT STATUS
The following exit values are returned:
0 All input files were output successfully.
> 0 An error occurred.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Availabilitysystem/core-os _ CSIEnabled _ Interface
StabilityCommitted _ StandardSee standards(7).
SEE ALSO
tac(1), touch(1), attributes(7), environ(7), standards(7)
NOTES
Redirecting the output of cat onto one of the files being read causes
the loss of the data originally in the file being read. For example,
example% cat filename1 filename2 > filename1
causes the original data in filename1 to be lost.
Oracle Solaris 11.4 19 Sep 2020 cat(1)