svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
break(1)
break(1) User Commands break(1)
NAME
break, continue - shell built-in functions to escape from or advance
within a controlling while, for, foreach, or until loop
SYNOPSIS
sh
break [n]
continue [n]
csh
break
continue
ksh88
*break [n]
*continue [n]
ksh
+break [n]
+continue [n]
DESCRIPTION
sh
The break utility exits from the enclosing for or while loop, if any.
If n is specified, break n levels.
The continue utility resumes the next iteration of the enclosing for or
while loop. If n is specified, resume at the n-th enclosing loop.
csh
The break utility resumes execution after the end of the nearest
enclosing foreach or while loop. The remaining commands on the current
line are executed. This allows multilevel breaks to be written as a
list of break commands, all on one line.
The continue utility continues execution of the next iteration of the
nearest enclosing while or foreach loop.
ksh88
The break utility exits from the enclosed for, while, until, or select
loop, if any. If n is specified, then break n levels. If n is greater
than the number of enclosing loops, the outermost enclosing loop shall
be exited.
The continue utility resumes the next iteration of the enclosed for,
while, until, or select loop. If n is specified then resume at the n-th
enclosed loop. If n is greater than the number of enclosing loops, the
outermost enclosing loop shall be used.
On this manual page, ksh88(1) commands that are preceded by one or two
* (asterisks) are treated specially in the following ways:
1. Variable assignment lists preceding the command remain in
effect when the command completes.
2. I/O redirections are processed after variable assignments.
3. Errors cause a script that contains them to abort.
4. Words that follow a command preceded by ** that are in the
format of a variable assignment are expanded with the same
rules as a variable assignment. This means that tilde sub‐
stitution is performed after the = sign, and also that word
splitting and file name generation are not performed.
ksh
break is a shell special built-in that exits the smallest enclosing
for, select, while, or until loop. It also exits the nth enclosing loop
if n is specified. Execution continues at the command following the
loop or loops.
If n is specified, it must be a positive integer ≥1. If n is larger
than the number of enclosing loops, the last enclosing loop is exited.
continue is a shell special built-in that continues execution at the
top of the smallest enclosing for, select, while, or until loop, if
any; or of the top of the nth enclosing loop if n is specified.
If n is specified, it must be a positive integer ≥1. If n is larger
than the number of enclosing loops, the last enclosing loop is used.
On this manual page, ksh(1) commands that are preceded by one or two +
symbols are special built-in commands and are treated the following
ways:
1. Variable assignment lists preceding the command remain in
effect when the command completes.
2. I/O redirections are processed after variable assignments.
3. Errors cause a script that contains them to abort.
4. Built-in commands are not valid function names.
5. Words following a command preceded by ++ that are in the
format of a variable assignment are expanded with rules as a
variable assignment. This means that tilde substitution is
performed after the = sign and field splitting and file name
generation are not performed.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Availabilitysystem/core-os
SEE ALSO
sh(1), csh(1), exit(1), ksh(1), ksh88(1), attributes(7)
Oracle Solaris 11.4 8 Apr 2008 break(1)