svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
creat(2)
creat(2) System Calls creat(2)
NAME
creat - create a new file or rewrite an existing one
SYNOPSIS
#include <sys/stat.h>
#include <fcntl.h>
int creat(const char *path, mode_t mode);
DESCRIPTION
The function call
creat(path, mode)
is equivalent to:
open(path, O_WRONLY | O_CREAT | O_TRUNC, mode)
RETURN VALUES
Refer to open(2).
ERRORS
Refer to open(2).
EXAMPLES
Example 1 Creating a File
The following example creates the file /tmp/file with read and write
permissions for the file owner and read permission for group and oth‐
ers. The resulting file descriptor is assigned to the fd variable.
#include <fcntl.h>
...
int fd;
mode_t mode = S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH;
char *filename = "/tmp/file";
...
fd = creat(filename, mode);
...
USAGE
The creat() function has a transitional interface for 64-bit file off‐
sets. See lf64(7).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardSee standards(7).
SEE ALSO
open(2), attributes(7), lf64(7), standards(7)
Oracle Solaris 11.4 25 Mar 2002 creat(2)