svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
zs_property(3zonestat)
Zones Statistics Library Functions zs_property(3ZONESTAT)
NAME
zs_property, zs_property_type, zs_property_string, zs_property_double,
zs_property_uint64, zs_property_int64, zs_property_uint, zs_prop‐
erty_int - libzonestat property value accessor methods
SYNOPSIS
cc [ flag ... ] file... -lzonestat [ library ... ]
#include <zonestat.h>
data_type_t zs_property_type(zs_property_t property);
char *zs_property_string(zs_property_t property);
double zs_property_double(zs_property_t property);
uint64_t zs_property_uint64(zs_property_t property);
int64_t zs_property_int64(zs_property_t property);
uint_t zs_property_uint(zs_property_t property);
int zs_property_int(zs_property_t property);
DESCRIPTION
These functions retrieve the values from zs_property_t objects.
The zs_property_type() function returns a value from the data_type_t
enumeration defined in <sys/nvpair.h>, which is one of:
tab(); lw(2.75i) lw(2.75i) lw(2.75i) lw(2.75i) ValueDatatype
DATA_TYPE_STRINGchar * DATA_TYPE_UINT64uint64_t DATA_TYPE_INT64int64_t
DATA_TYPE_UINT32uint_t DATA_TYPE_INT32int DATA_TYPE_DOUBLEdouble
The zs_property_string() function returns a char * pointing to a
string. Callers must copy this string in order to retain it after free‐
ing the zs_usage_t object from which this property was obtained.
The zs_property_uint64(), zs_property_int64(), zs_property_uint(),
zs_property_int(), and zs_property_double() functions return the value
contained in the property object.
RETURN VALUES
See Description.
ERRORS
If a zs_property_*() function is called with a property of the wrong
type, the function will abort with abort(3C).
EXAMPLES
See zs_pset_zone(3ZONESTAT).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe
SEE ALSO
zonestat(1), abort(3C), libpool(3LIB), libzonestat(3LIB), zs_open(3ZON‐
ESTAT), zs_pset(3ZONESTAT), zs_pset_zone(3ZONESTAT), zs_resource(3ZONE‐
STAT), zs_usage(3ZONESTAT), zs_zone(3ZONESTAT), attributes(7),
resource-controls(7), pooladm(8), psrset(8), rcapadm(8), swap(8),
zoneadm(8), zonestatd(8)
Oracle Solaris 11.4 13 Nov 2020 zs_property(3ZONESTAT)