svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
wsscanf(3c)
Standard C Library Functions wsscanf(3C)
NAME
wsscanf - formatted input conversion
SYNOPSIS
#include <stdio.h>
#include <widec.h>
int wsscanf(wchar_t *s, const char *format, /* pointer */ ... );
DESCRIPTION
The wsscanf() function reads Process Code characters from the Process
Code string s, interprets them according to the format, and stores the
results in its arguments. It expects, as arguments, a control string
format, and a set of pointer arguments indicating where the converted
input should be stored. The results are undefined if there are insuffi‐
cient args for the format. If the format is exhausted while args
remain, the excess args are simply ignored.
The conversion specifications and behavior of wsscanf() are the same as
the regular sscanf(3C) function except that the source is a Process
Code string for wsscanf() and on Extended UNIX Code (EUC) character
string for sscanf(3C).
RETURN VALUES
Upon successful completion, wsscanf() returns the number of characters
matched. Otherwise, it returns a negative value.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe
SEE ALSO
printf(3C), scanf(3C), wsprintf(3C), attributes(7)
Oracle Solaris 11.4 11 May 2021 wsscanf(3C)