svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
wsprintf(3c)
Standard C Library Functions wsprintf(3C)
NAME
wsprintf - formatted output conversion
SYNOPSIS
#include <stdio.h>
#include <widec.h>
int wsprintf(wchar_t *s, const char *format, /* arg */ ... ););
DESCRIPTION
The wsprintf() function outputs a Process Code string ending with a
Process Code (wchar_t) null character. It is the user's responsibility
to allocate enough space for this wchar_t string.
This returns the number of Process Code characters (excluding the null
terminator) that have been written. The conversion specifications and
behavior of wsprintf() are the same as the regular sprintf(3C) function
except that the result is a Process Code string for wsprintf(), and on
Extended UNIX Code (EUC) character string for sprintf().
RETURN VALUES
Upon successful completion, wsprintf() returns the number of characters
printed. Otherwise, a negative value is returned.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe
SEE ALSO
printf(3C), scanf(3C), sprintf(3C), wsscanf(3C), attributes(7)
Oracle Solaris 11.4 11 May 2021 wsprintf(3C)