svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
wcsxfrm(3c)
Standard C Library Functions wcsxfrm(3C)
NAME
wcsxfrm, wcsxfrm_l, wsxfrm - wide character string transformation
SYNOPSIS
#include <wchar.h>
size_t wcsxfrm(wchar_t *ws1, const wchar_t *ws2, size_t n);
size_t wcsxfrm_l(wchar_t *ws1, const wchar_t *ws2, size_t n, locale_t locale);
size_t wsxfrm(wchar_t *ws1, const wchar_t *ws2, size_t n);
DESCRIPTION
The wcsxfrm() and wcsxfrm() functions transform the wide character
string pointed to by ws2 and place the resulting wide character string
into the array pointed to by ws1. The transformation is such that if
either the wcscmp(3C) or wscmp(3C) functions are applied to two trans‐
formed wide strings, they return a value greater than, equal to, or
less than 0, corresponding to the result of the wcscoll(3C) or
wscoll(3C) function applied to the same two original wide character
strings. No more than n wide-character codes are placed into the
resulting array pointed to by ws1, including the terminating null wide-
character code. If n is 0, ws1 is permitted to be a null pointer. If
copying takes place between objects that overlap, the behavior is unde‐
fined.
The fact that when n is 0, ws1 is permitted to be a null pointer, is
useful to determine the size of the ws1 array prior to making the
transformation.
The wcsxfrm() and wsxfrm() functions do not change the setting of errno
if successful.
Since no return value is reserved to indicate an error, an application
wishing to check for error situations should set errno to 0, then call
wcsxfrm() or wsxfrm(), then check errno.
The wcsxfrm_l() function is equivalent to the wcsxfrm() function,
except that the locale data used is from the locale represented by
locale.
The behavior is undefined if the locale argument to wcsxfrm_l() is the
special locale object LC_GLOBAL_LOCALE or is not a valid locale object
handle.
RETURN VALUES
These functions return the length of the transformed wide character
string (not including the terminating null wide-character code). If the
value returned is n or more, the contents of the array pointed to by
ws1 are indeterminate.
On error, these functions may set errno but no return value is reserved
to indicate an error.
ERRORS
These functions may fail if:
EINVAL The wide character string pointed to by ws2 contains wide-
character codes outside the domain of the collating sequence.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ CSIEnabled _ Interface Stabilitywcsxfrm() and
wcsxfrm_l() are Standard _ MT-LevelMT-Safe
SEE ALSO
wscoll(3C), duplocale(3C), freelocale(3C), newlocale(3C), setlo‐
cale(3C), uselocale(3C), wcscmp(3C), wcscoll(3C), wscmp(3C),
attributes(7), standards(7)
Oracle Solaris 11.4 6 Oct 2014 wcsxfrm(3C)