svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
wcswidth(3c)
Standard C Library Functions wcswidth(3C)
NAME
wcswidth - number of column positions of a wide-character string
SYNOPSIS
#include <wchar.h>
int wcswidth(const wchar_t *pwcs, size_t n);
DESCRIPTION
The wcswidth() function determines the number of column positions
required for n wide-character codes (or fewer than n wide-character
codes if a null wide-character code is encountered before n wide-char‐
acter codes are exhausted) in the string pointed to by pwcs.
RETURN VALUES
The wcswidth() function either returns 0 (if pwcs points to a null
wide-character code), or returns the number of column positions to be
occupied by the wide-character string pointed to by pwcs, or returns −1
(if any of the first n wide-character codes in the wide-character
string pointed to by pwcs is not a printing wide-character code).
ERRORS
No errors are defined.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ CSIEnabled _ Interface StabilityCommitted _ MT-LevelMT-
Safe _ StandardSee standards(7).
SEE ALSO
setlocale(3C), wcwidth(3C), attributes(7), standards(7)
Oracle Solaris 11.4 7 Oct 2014 wcswidth(3C)